SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict
    Join Date
    Dec 2004
    Location
    San Francisco
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Error on automatic inclusion of %09, %26 in the URL

    Hi there,

    I have developed a website in php with the MySQL database as the backend. I have even hosted the website and everything is working fine. With apache modrewrite I made my dynamic URLS look like static. Again the site is working fine with the new static URLS too. When I checked my server log for errors, I am find finding some of the errors like these:

    /name/S%26amp;page150%26amp;limit25
    /state/%09AK
    /program/%0938


    Can anyone explain what are these %26, %09 and why are these being automatically included in the URL. Is there any way of stopping this, as I dont want my visitors to suffer with the error pages (which means losing the users).

    Thanks in advance.

  2. #2
    gimme the uuuuuuuuuuu duuudie's Avatar
    Join Date
    Feb 2004
    Location
    Switzerland
    Posts
    2,253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi
    it has to do with url encoding. Ut's hard to tell what exactly the problem is without looking at your whole app.
    Check the manual and follow a few links to the functions that deal with url encoding and I'm sure you'll sort that out very easily:
    http://ch2.php.net/manual/en/ref.url.php
    this one is pretty explanative:
    http://ch2.php.net/urlencode


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •