SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Sep 2003
    Location
    Finland
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help needed with imap_body()

    When extracting the body text of emails, I notice 2 problems:

    1) There's automatic CR/LF after around 70 characters or so and an "=" sign at the end of each line.

    2) The following characters aren't displayed properly: .

    In other words, the following email body text:

    Test message with a long enough sentence and special characters: $ .

    Appears like this:

    Test message with a long enough sentence and special characters: =E4 =F6 =
    =E5 EUR =A3.

    Does anyone know how to fix this? Thanks!

    - Aylwin -

  2. #2
    SitePoint Enthusiast
    Join Date
    Mar 2005
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi there,

    try playing arround with functions like "quoted_printable_decode"

  3. #3
    SitePoint Member
    Join Date
    Sep 2003
    Location
    Finland
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply! I think that put's me on the right track.

    The message now appears as:

    Test message with a long enough sentence and special characters: � � � EUR �.

    It's now a single line as it should be. The special characters aren't decoding corectly though. Any more ideas regarding this?

    - Aylwin -

    edit:
    Fixed it! All I had to do was set the default charset to iso-8859-1.
    Thanks again for your help!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •