SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Mar 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Linked Text Problem in IE 5 for Mac

    i've created a list of linked text within a table that is nested within a table cell. the problem is that in Mac IE 5, the text seems to expand when the length of the linked text wraps to the next line. the text wraps to the next line after the word "Short", and then there is a big gap of space that is added. what could be causing this? this does not happen in netscape, or on the pc. i think i've mucked something up somewhere, but i'm having trouble figuring out what i've done wrong. this is the style i have for the link:

    .detTxt {
    font: normal 12px/1.2em times, serif;
    color: #350809;
    text-align: left;
    letter-spacing:0.1em;
    padding-top: 12px;
    padding-bottom: 2px;
    padding-left: 10px;
    padding-right: 4px;
    vertical-align: top;
    }
    A.detTxt:link {
    font: normal 12px/1.2em times, serif;
    color: #350809;
    text-align: left;
    letter-spacing:0.1em;
    padding-top: 12px;
    padding-bottom: 0px;
    padding-left: 0px;
    padding-right: 0px;
    text-decoration: underline;
    vertical-align: top;
    }
    A.detTxt:visited {
    font: normal 12px/1.2em times, serif;
    color: #350809;
    text-align: left;
    letter-spacing:0.1em;
    padding-top: 12px;
    padding-bottom: 0px;
    padding-left: 0px;
    padding-right: 0px;
    text-decoration: underline;
    vertical-align: top;
    }

    thank you for any help!
    --robbie--
    Last edited by brooklynGuy; Mar 28, 2005 at 13:20.

  2. #2
    SitePoint Member
    Join Date
    Mar 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i got it to work a _little_ better. i removed all the padding (top, right, left, bottom) values from the style detTxt. and the space decreased some. but a block of empty space _still_ appears if a line of linked text wraps to the next line.
    i've also noticed that this empty space is linked -- if you place the mouse over the left area of the space... weird.

    is there anyway to fix this? i'll keep trying. if i find a solution, i'll post it here --- in case anyone else has this problem. thanks for any help you can offer!
    --robbie--

  3. #3
    SitePoint Member
    Join Date
    Mar 2005
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i just removed the vertical-align: top; and that seemed to work. i'm not sure why this caused a problem... but --- it has stopped the space frome appearing when the linked text wraps. thanks to anyone who saw this and may have tried to help. but it seems ok now.

    --robbie--


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •