SitePoint Sponsor

User Tag List

Results 1 to 8 of 8

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    May 2001
    Location
    Washington State
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Module is Garbled?

    Shutting down http: [ OK ]
    Starting httpd:
    Syntax error on line 70 of /etc/httpd/conf/httpd.conf:
    API module structure `php4_module' in file /etc/httpd/modules/libphp4.so is garble
    d - perhaps this is not an Apache module DSO?
    [FAILED]

    any ideas what this error means?

    I got it when i edited my httpd.conf file and went to restart the daemon with php modules active.

  2. #2
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Gilroy, CA
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm getting the exact same error.

  3. #3
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Gilroy, CA
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have some info that might help. I went back through the PHP configure and noticed the following:
    Configuring SAPI modules
    checking for AOLserver support... no
    checking for Apache module support via DSO through APXS... apxs:Warning: /usr/sb
    in/httpd not found or not executable
    apxs:Warning: Continuing anyway...
    apxs:Warning: Sorry, no DSO support for Apache available
    apxs:Warning: under your platform. Make sure the Apache
    apxs:Warning: module mod_so is compiled into your server
    apxs:Warning: binary `/usr/sbin/httpd'.
    apxs:Warning: Continuing anyway...
    apxs:Warning: /usr/sbin/httpd not found or not executable
    apxs:Warning: Continuing anyway...
    apxs:Warning: Sorry, no DSO support for Apache available
    apxs:Warning: under your platform. Make sure the Apache
    apxs:Warning: module mod_so is compiled into your server
    apxs:Warning: binary `/usr/sbin/httpd'.
    apxs:Warning: Continuing anyway...
    apxs:Warning: /usr/sbin/httpd not found or not executable
    apxs:Warning: Continuing anyway...
    apxs:Warning: Sorry, no DSO support for Apache available
    apxs:Warning: under your platform. Make sure the Apache
    apxs:Warning: module mod_so is compiled into your server
    apxs:Warning: binary `/usr/sbin/httpd'.
    apxs:Warning: Continuing anyway...
    apxs:Warning: /usr/sbin/httpd not found or not executable
    apxs:Warning: Continuing anyway...
    apxs:Warning: Sorry, no DSO support for Apache available
    apxs:Warning: under your platform. Make sure the Apache
    apxs:Warning: module mod_so is compiled into your server
    apxs:Warning: binary `/usr/sbin/httpd'.
    apxs:Warning: Continuing anyway...
    yes
    checking for mod_charset compatibility option... no
    checking for Apache 2.0 module support via DSO through APXS... no
    checking for Caudium support... no
    checking for fhttpd module support... no
    checking for FastCGI support... no
    checking for Zeus ISAPI support... no
    checking for NSAPI support... no
    checking for PHTTPD support... no
    checking for Pi3Web Support... no
    checking for Roxen/Pike support... no
    checking for Servlet support... no
    checking for thttpd... no
    checking for chosen SAPI module... apache

  4. #4
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Gilroy, CA
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Disregard the APXS error

    Don't pay any attention to the above. It was my mistake, I removed the Apache RPM because I didn't want to get it confused with the one installed from scratch. I fixed the APXS error but still have the garbled module error.

  5. #5
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Gilroy, CA
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I've got the answer to garbled

    Iwas having the same problem. The solution was easy. Just use --with-apxs=/full/path/to/apxs.

    Before you decide the full path, do a "find / -name apxs" to see how many different ones you have.

    I download the the apache tar file to /usr/local/src and it unzipped to /usr/local/src/apace_1.3.19. There is a copy of apxs under this install but it's not the one you want to reference. The one I needed to specify was /usr/local/apache/bin. This is also the directory you want to use for configuration and starting/stopping the server.

    Good luck.

    Let me know if it doesn't work for you.
    Bernn

  6. #6
    SitePoint Member
    Join Date
    May 2001
    Location
    Washington State
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    but it IS installed

    i had apxs installed and working correctly even before i had this problem, even downloaded the newer version of it in an .rpm before i started this project.

  7. #7
    SitePoint Enthusiast
    Join Date
    May 2001
    Location
    Gilroy, CA
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    re: apxs already installed

    Mine was installed and working properly also, but I think I was referencing the wrong directory.

  8. #8
    SitePoint Member
    Join Date
    Jun 2001
    Location
    MA
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I am having the same problem (HELP)

    I got the same problem and I have apxs installed in the right place and I told the configuration that it was there. I am following a guide to install php and the only thing I did different from the guide was that I didn't install mysql from scratch because the server had one already installed at a different location though. I don't know if that could be the problem. I would really appreciate it if someone could help me. Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •