SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Feb 2005
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    valid xhtmlpage freaks out in IE, Firefox and Opera OK

    edit: url removed;

    its valid xhtml 1.0 Strict, everything was fine... the page looking the same in all browsers. then all of a sudden IE freaks out on the menu. i think i have located the problem to the dl elements in the left column but the thing is it worked before. what i did change i reverted but no change of apperance. the page still looked like a mess.

    (dont mind the language, its swedish...)

    im going crazy over hehe :'( can someone locate the problem?

    edit: i think i solved the problem myself. my php-output seemed to cause the problem. in the sourcecode a large part of the code in the menusection was in one long row. IE didnt seem to be able to handle that but Firefox and Opera does. I think this was a really strange explanation but its the only one i have. can someone confirm it?

  2. #2
    CSS & JS/DOM Adept bronze trophy
    Join Date
    Mar 2005
    Location
    USA
    Posts
    5,482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seeing the code would help.
    We miss you, Dan Schulz.
    Learn CSS. | X/HTML Validator | CSS validator
    Dynamic Site Solutions
    Code for Firefox, Chrome, Safari, & Opera, then add fixes for IE, not vice versa.

  3. #3
    SitePoint Member
    Join Date
    Feb 2005
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeah sorry, i removed the url when i solved the problem. but still...can anyone confirm that IE cant handle if some blocks of the sourcecode is all in one row. All i did to fix the problem was adding a \n in the php-generation of the output...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •