SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    May 2001
    Location
    Adelaide, Australia
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Installing PHP on RedHat 7.0

    I read the article that is up on installing MySQL and PHP, and followed it pretty much to the letter. Everything was going well (no errors, etc.) until I tried to test it . . . I used the sample php script that was there, and it didn't work. It showed the normal HTML, but the php side just didn't happen.

    I think it might be my php.ini file. I was wondering if you could tell me what the doc_root and extensions_dir are supposed to be . . .

    Thanks,
    Matt

  2. #2
    Irritability Defined
    Join Date
    Jul 2000
    Location
    80,000 feet below the surface
    Posts
    1,442
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you added the Apache directives within httpd.conf?

    And what do you mean by the 'normal HTML'? If you do a sample page (name it test.php) with :

    <? php
    phpInfo()
    ?>

    And you see a huge page full of tables with PHP configuration options + other stuff then it means PHP has worked.

    If you see a blank page it means that you haven't made the necessary modifications within httpd.conf or there is something amiss with php.ini - check the instructions very carefully.

    Good luck.
    My 2 Cents (or is that 2.2 Cents including GST?)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •