SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Evangelist ktown's Avatar
    Join Date
    May 2001
    Location
    toronto
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    tables... netscape just doesn't like mine

    Hey all,

    i have a table thats inside a table cell that doesn't have a specified width... my table is set to 95% but for some reason in NS4.x it jams into the side when you try to resize it to be smaller...

    http://www.epples.ca/thermal/webfile...emis_cont.html

    looks ugly huh?

    i tried to add a cell that would work as a spacer with an blank image in it but thats not helping... any suggestions?

    THX

  2. #2
    I believe you have my stapler. scrubz's Avatar
    Join Date
    Feb 2001
    Location
    Van down by the river
    Posts
    254
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmmm, looks fine from here. What part of the page are we talking about?

  3. #3
    SitePoint Evangelist ktown's Avatar
    Join Date
    May 2001
    Location
    toronto
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I was talking about if you preview in NS4.x and try to make the page smaller... like thinner i guess... and the table is supposed to resize but for some reason the the right side of the table.. inside the page.. the orange one.. jams into the border of the browser window...

    do you see it?

  4. #4
    SitePoint Zealot Overgrow's Avatar
    Join Date
    Jan 2001
    Location
    Your basement
    Posts
    192
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    NS 4.77 and IE 5.x both render it exactly the same. Netscape 4.77 does resize it correctly as well. Since I don't do any QA here, I don't have my typical 20 versions of Netscape, but it's highly likely that the pre 4.51 versions will have these resize problems like you describe.

    Check out the <body onResize=""> command and I bet you can get around it with a page reload. Of course only print out that onresize if the browser is in that heap-of-junk that won't resize properly.
    Overgrow the Government: The Edge Forums
    presented by Overgrow Marijuana Magazine

    *warning: adult content

  5. #5
    SitePoint Evangelist ktown's Avatar
    Join Date
    May 2001
    Location
    toronto
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok. i downloaded ns4.77 and it does resize properly

    BUT in the earlier versions of netsape (which is what i use for testing 4.51) it still resizes it funny... its like the orange table is getting jammed into the side but is still making cells thinner at the same time, ok its kind of like its too dumb to leave a margin..

    does anyone have any idea what i'm talking about?

    since i'm doing this site for a client that has many customers overseas (like china) where browsers actually are an issue, this kind of buggs me but i can't figure out whats wrong or even IF i can fix it.

    what is <body onResize=""> ?

  6. #6
    SitePoint Evangelist ktown's Avatar
    Join Date
    May 2001
    Location
    toronto
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just bringing the thread back up to the top for any possible advice.. its versions of NS before 4.77 that mess it up

  7. #7
    SitePoint Guru
    Join Date
    Sep 1999
    Location
    Singapore
    Posts
    854
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •