SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: Firefox Problem

  1. #1
    SitePoint Zealot
    Join Date
    Oct 2004
    Location
    Middlesbrough, UK
    Posts
    138
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Firefox Problem

    I've been trying to work out this problem for what feels like an age now, but can't seem to fathom out what's wrong. The page displays fine in internet explorer, but Firefox inserts a massive gap at the top of the content area.

    http://www.skybiz.co.uk/speeddating/specificevent.php

    Any ideas?

    Cheers.

  2. #2
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't know after a quick play with it, but you can fix it by adding this hack:
    Code:
    html>body #subcont {
    margin-top: -290px;
    }

  3. #3
    SitePoint Zealot
    Join Date
    Oct 2004
    Location
    Middlesbrough, UK
    Posts
    138
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help, but should it really require a hack to fix it? Surely it must be an error I've made somewhere along the line.

  4. #4
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, but I don't have time to deconstruct it sufficiently to figure out where you've gone wrong.

    It's obvious that the content block is getting pushed down below the navigation block. Try taking out all the content and colouring the container blocks - that might help in seeing where the problem is occurring.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •