SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Feb 2005
    Location
    UK
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unidentified script...

    Hi. This might be a really stupid question, I'm quite new to this, but could anyone explain to me the following script which appears in the head section of my site when I upload and view source. I didn't put it there and it's not on my local version of the site:

    <script language='javascript' src='http://127.0.0.1:1025/js.cgi?pca&r=19589'></script>

    It links to a bunch of script that I don't really understand:

    var blockedReferrer = 'blockedReferrer';
    NS_ActualWrite=document.write;
    // Popup Blocker -->
    RanPostamble=0;
    NS_ActualOpen=window.open;
    function NS_NullWindow(){this.window;}
    function nullDoc() {
    this.open = NS_NullWindow;
    this.write = NS_NullWindow;
    this.close = NS_NullWindow;
    }
    etc etc.....

    that's just the start of it.

    There's probably a simple explanation, but I just wanted to double check it's not anything malicious. It's never appeared on any of my other sites.

    Thanks for your help.
    Tom

  2. #2
    Non-Member
    Join Date
    Jan 2005
    Location
    Netherlands
    Posts
    4,300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    just a guess

    file uploaded with norton antivirus Enabled?

  3. #3
    SitePoint Member
    Join Date
    Feb 2005
    Location
    UK
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    AVG actually, but this hasn't affected anything else I've uploaded.

    I just had a look at the remote file on my hosting company's server, and I can't see the script there either. only when I 'view source' through a browser.

    hmm.

  4. #4
    Non-Member
    Join Date
    Jan 2005
    Location
    Netherlands
    Posts
    4,300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello

    Popup blocker from Zonealarm?, search with Yahoo or google or search Sitepoint

  5. #5
    SitePoint Member
    Join Date
    Feb 2005
    Location
    UK
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think you must be right. I've turned Zonealarm off and I can't see it now.
    I still don't really understand why it didn't show up on other sites though.

    Thanks a lot for your help.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •