SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    I see geek people adris72's Avatar
    Join Date
    Feb 2005
    Location
    NYC
    Posts
    227
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    yet another javascript/ W3C problem

    Hi

    I'm using a javascript menu , maybe some of you know it, the tigra menu. Costumer requires that kind of drop-down menu, so I have to use it.
    My problem here is that xhtml won't validate.
    I tried to fix the tags in the proper way:
    <script type="text/javascript" language="javascript" src="menu.js"></script>
    <script type="text/javascript" language="javascript" src="menu_tpl.js"></script>
    <script type="text/javascript" language="javascript" src="menu_items.js"></script>

    but then the menu won't work, it wont even show up.

    You can test the live page (working and not validating) at http://www.misalud.com/temp/index-eng.html

    Anybody that can help me to validate this? thank you in advance.

  2. #2
    Non-Member
    Join Date
    Jan 2005
    Location
    Netherlands
    Posts
    4,300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hello try this:

    <script type="text/javascript" language="javascript" src="menu.js"></script>

    <script type="text/javascript" type="text/javascript" src="menu.js"></script>

  3. #3
    I see geek people adris72's Avatar
    Join Date
    Feb 2005
    Location
    NYC
    Posts
    227
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry all4nerds, I tried it and the menu desapeared again Thank you anyway.

  4. #4
    Non-Member
    Join Date
    Jan 2005
    Location
    Netherlands
    Posts
    4,300
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello

    i have the html on my computer

    type="text/javascript" must be in all your script links and tags

    i also changed this
    <input id="searchmisalud" name="sitesearch" checked= "checked"

    you als have script at the end or better outside your
    </html>

    it now validates at w3c now

    use this link on your page (Temporarily)
    <a href="http://validator.w3.org/check?uri=referer">validate</a>

  5. #5
    I see geek people adris72's Avatar
    Join Date
    Feb 2005
    Location
    NYC
    Posts
    227
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you very much!!!!!
    Now it validates for me too!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •