SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Evangelist on_way_to_fame's Avatar
    Join Date
    Jun 2004
    Location
    UK
    Posts
    423
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    mod rewrite doesnt work on localhost

    Hi..i installed my phpbb forums on localhost and then restored the backup..of my main site on localhost..so thqat i could use it for testing..now the problem i am having is...whenever i click on any forum..it shows a 404 not found error...i am using a rewrite mod...which converts everything into HTML..and works fine on my site...any suggestions on how i can solve this problem ?

  2. #2
    SitePoint Evangelist on_way_to_fame's Avatar
    Join Date
    Jun 2004
    Location
    UK
    Posts
    423
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok..i realised it was because i forgot to put to .htaccess file..but after i put it..it shows the following error..

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    --------------------------------------------------------------------------------

    Apache/2.0.52 (Win32) mod_ssl/2.0.52 OpenSSL/0.9.7e PHP/5.0.3 Server at localhost Port 80
    what could it be ? php - 5.0.3 ????? or something else ?

    while installing phpBB i selected 4. version of php.

  3. #3
    Gone!
    Join Date
    Aug 2001
    Location
    Witty Location Parody
    Posts
    3,889
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Moved to the Apache forum

  4. #4
    SitePoint Wizard Dean C's Avatar
    Join Date
    Mar 2003
    Location
    England, UK
    Posts
    2,906
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Open up your apache configuration file (httpd.conf) and make sure the "AllowOveride" setting is set to all And secondly make sure this line: LoadModule rewrite_module modules/mod_rewrite.so doesn't have a # character before it. If it does remove it

  5. #5
    SitePoint Evangelist on_way_to_fame's Avatar
    Join Date
    Jun 2004
    Location
    UK
    Posts
    423
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks...allow override settingwas set to all...and case two did have a # but i removed it as you said...but the error still shows up ?

    what next ?

  6. #6
    SitePoint Wizard Dean C's Avatar
    Join Date
    Mar 2003
    Location
    England, UK
    Posts
    2,906
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What is is in that .htaccess file ?

  7. #7
    SitePoint Evangelist on_way_to_fame's Avatar
    Join Date
    Jun 2004
    Location
    UK
    Posts
    423
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks solved it now..actually i forgot to restart apache after making the changes..cheers

  8. #8
    SitePoint Wizard Dean C's Avatar
    Join Date
    Mar 2003
    Location
    England, UK
    Posts
    2,906
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by on_way_to_fame
    Thanks solved it now..actually i forgot to restart apache after making the changes..cheers
    Hehe I hate it when that happens Glad you got it sorted though!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •