SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict frankiehots's Avatar
    Join Date
    Jan 2002
    Location
    U.S.A. *Blue State*
    Posts
    289
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Upgrade to MySQL 4.1 caused phpMyAdmin Warning

    Just had my host upgrade MySQL from 4.0.17 to 4.1.9 and now when I run phpMyAdmin I get the following warning:

    "The mbstring PHP extension was not found and you seem to be using multibyte charset. Without mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results."

    Anyone have any idea how I might correct this?

  2. #2
    Employed Again Viflux's Avatar
    Join Date
    May 2003
    Location
    London, On.
    Posts
    1,127
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I imagine you'll have to rebuild PHP with mbstring support (Linux) or fix up your php.ini (Windows). Rather, have your host.

    If you don't, you will likely run into problems when working with UTF-8 strings (from the phpmyadmin sourceforge forum).

    Google can help

  3. #3
    SitePoint Addict frankiehots's Avatar
    Join Date
    Jan 2002
    Location
    U.S.A. *Blue State*
    Posts
    289
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Viflux, you were pretty much right on. My host recompiled PHP (server OS is FreeBSD) and added mbstring support and the warning is gone. I got started in the right direction by reading this thread on the SourceForge/phpMyAdmin forums:

    Understanding the mbstring configs?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •