SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast PHPmySQLer's Avatar
    Join Date
    Jan 2005
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Nooobeeeee questions

    Hi. I have three newbie questions.

    1) Can somebody help me figure out why mysqld stopped working? I thought I had mySQL configured correctly because I was able to do everything without getting errors, but now I can't run mysqld, and I'm sure it's affecting my being able to access my database. I was starting mysqld with the mySQL Command Prompt and entering my root user password with no problem. Now the mySQL Command Prompt disappears and I hear a beep after I enter my password. Before I re-install mySQL, is there something I should check? I can run mysql and mysqladmin, etc. Is there a correct order of installing Apache, PHP and mySQL? I re-installed Apache and PHP and things seem to be working fine.

    2) I am trying to access the tutorial database from PHP and mySQL Web Develpment (2nd Ed.), but the error says "Cannot connect to the database. Please try again later". The strings(?) for the connect function is ....('localhost', 'bookorama', 'bookorama123')...I'm assuming this is because I don't have mysqld running, but then I thought, "Do I need to change the strings, or arguments(?), whatever they are called"? What is the string 'bookorama' referring to and where is it calling it from? I know it's the :/socketpath, but that doesn't make sense to me yet. I know 'bookorama' is the password, but how is that changed?

    so....

    3) Where can I find a beginner's checklist of all these things: Apache, PHP and mySQL (in one place)? I have been able to get by for now, but my troubleshooting technique is very cumbersome and lethargic. I will be scouring the forums for this info, but I thought I would go ahead and post a thread and see if anybody sees any obvious weaknesses on my part.

    Sorry a) if I left any important info out or b) if my questions are too complex.

  2. #2
    SitePoint Enthusiast PHPmySQLer's Avatar
    Join Date
    Jan 2005
    Posts
    31
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I figured it out

    I changed ('localhost', 'bookorama', 'bookorama123') to ('localhost', 'root', 'mypassword') and by god it worked.

    I thought I already tried that. It seemed too easy.
    Thanks for your help anyway.

    No more stupid questions.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •