SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Feb 2005
    Location
    Auckland, New Zealand
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Lots of PHP v4 hosting but little PHP v5 - Why?

    I started learning PHP with version 5 and have created a whole lot of classes etc using the new features. Which is fine in my own development site. But where are the web hosts that support PHP v5? In New Zealand at least, host after host has v4 only. Is it the same elsewhere? Does anyone have any ideas about what is going on? PHP v5 has been out a while and is stable so what is the story? And how did the transition from v3 to v4 go last time round?

  2. #2
    SitePoint Zealot Ap0s7le's Avatar
    Join Date
    Jul 2003
    Location
    Lousiville, KY
    Posts
    118
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I know here it's all v4 due to v5 not being "old enough and time tested"
    Personally I still do v4 on my dev machines due to so many aren't familiar with the new.

    so long

  3. #3
    SitePoint Guru
    Join Date
    Nov 2004
    Location
    Parry Sound, ON
    Posts
    725
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Mainly because the major distros still package PHP4. Probably no other reason.

  4. #4
    Non-Member john.stone's Avatar
    Join Date
    Aug 2004
    Location
    Houston, Texas
    Posts
    555
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Because php 4 has been around... Most hosts know it in and out... up and down... It's stable... Properly functioning in their environment and honestly have no reason upgrade.

    Upgrading takes time, which costs money. PHP 5 might break some of their clients scripts, which will take more time to fix (if fixable). So it's really a no win situation.

  5. #5
    SitePoint Member
    Join Date
    Feb 2005
    Location
    Auckland, New Zealand
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Regarding Linux distros, when is PHP v5 likely to be included? And did the same issues delay the transition from v3 to v4? How long are we likely to wait? I really like v5!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •