SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict
    Join Date
    Dec 2003
    Location
    Raleigh, NC
    Posts
    278
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    help with menu...

    Hello,

    I have modified the youngpup slide menu to my suiting. I have started from what http://www.bbcbroadcast.com/whoweare/index.shtml was using.

    But I have a few bugs that I need help with.

    1- Explorer 5 for mac - All other browsers display in the proper position fine. IE Mac however has the menu down the page a little....it looks like it is starting from the top of the bottom as a co-ordinate instead of the body. Anyone know how to fix it?

    2- Firefox - Getting a weird flickering effect when i rollover the buttons...at least on the mac version of Firefox. It doesnt do this for the BBC site listed above. Also, I am getting this weird outline when I click down on the buttons in its activated state...it also goes beyond the right edge. It also doesnt do this on the other site. I noticed if I take the explicit with off the li's in the mens.css it goes away.

    3- Explorer 5 for PC - I am getting gaps below each li. Works fine on other versions of IE for PC. I know about the whitespace bug in Explorer but I added a space right before each ending a link and it still did it.

    Over all display fine in Explorer, except it starts at a slighty hight position than other browsers.

    Im using that MS alpha filter.

    Any help is appreciated for help on this.

    The url is http://www.kevinevans.net/bcbs/welcomeSlide.html

    Kevin

  2. #2
    SitePoint Addict
    Join Date
    Dec 2003
    Location
    Raleigh, NC
    Posts
    278
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's funny, been using CSS for like 2 years now and I am pretty good at it except I always have problem with menus like this one.

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,276
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Here's one of the problems solved.

    3) for ie5 add this:
    Code:
    /* mac hide \*/
    * html .menuInner ul {height:1%;}
    /* end hide*/
    * html .menuInner li {display:inline}
    Sorry I haven't been able to check the other problems. You can always hack the start position for ie if you can't find the start position.

    I notice you have used 100% widths and also added padding. This will make it bigger than its parent in some cases so that could be your problem in firefox.

    Ie mac has problems with positioning and will inherit some positions into the children. Try using margins to place the element in question.

    Paul

  4. #4
    SitePoint Addict
    Join Date
    Dec 2003
    Location
    Raleigh, NC
    Posts
    278
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Paul!

    I think I found the problem with the mac being positioned down farther. Its a table layout. I moved the menu above all the tables in the markup and it worked. Is there a way to keep the menus inside the tables and still be fine in IE for mac?

    Kevin


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •