SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Dec 2004
    Location
    American Samoa
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Problem with installing and configuring IIS

    Hi, lately i've been working on installing PHP 5.0.2 and MYSql4.1.7 on my machine. My machine runs a Windows XP Media Center Edition OS. I want to use my machine as a WebServer so I can run and test some PHP page before I do the actual installation on our main webserver. I'm so new at this stuff so please when you answer give me steps to steps explanations on how to fix or where to look into to solve this problem. My problem I think is the configuration of IIS on my machine but then i'm not sure.

    This is what happened. According to Kevin Yank's book that i bought entitled Building Your Own Database Driven Website Using PHP and MySQL 2nd Edition and trial 4chapters 3rd Edition from on this site, i should open up the Properties for Default Website inside the IIS Services inside administrative services. I was able to do all the other stuff like add PHP inside the ISAPI Filters but when trying to click on the Application configuration button inside the Home Directory, it won't bring up anything so i can add php5isapi.dll inside the Mappings... . Since I wasnt able to do this, I just skipped and went on to installing PHP and MySQL server on my machine, the same one i installed IIS on. After installing PHP, I did everything that was told in the book like renaming the php.ini file, etc. at first I had a message saying unable to load dynamic library php_mysql.dll . I went in this forum earlier and was able to find where my problem was at and that was i didn't move the php_mysql.dll file inside the C:\PHP directory, after i did this, reboot my machine and the error message didn't come up anymore, so i assume that now the dynamic library is now being found and able to load? the problem is now fixed?

    Thinking that it should be working, so to test I wrote down the first scirpt that's in the book and saved it inside the root folder C:\inetpub\wwwroot\ in IIS. After saving i went to bring this page up using http://local-host/today.php and it says Page Cannot be Displayed. Do you knw why this is happening? Could it be the IIS? PHP? or MySQL? Help.

    Thank you,
    Poly808

  2. #2
    Afrika
    Join Date
    Jul 2004
    Location
    Nigeria
    Posts
    1,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    its http://localhost/
    not local-host

    try that and see if it works

    put your files in a folder in the www root and point the default folder to it, and set the default document as well and test this
    rgds
    afrika

  3. #3
    SitePoint Member
    Join Date
    Dec 2004
    Location
    American Samoa
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi afrika, thanks for the reply. yes i did tried that too but still it won't work. is it possible that IIS can be configured on a Windows XP Media Center OS? just wondering, that could be the reason why it's not working.

    thanks,
    poly808

  4. #4
    SitePoint Member
    Join Date
    Jul 2004
    Location
    PA, USA
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up PHP5 & IIS

    Poly,

    Perhaps you haven't configured the .php extension under IIS. Unless that is done, you will not be able to access any .php file through IIS (i.e. http://localhost). Once you get this done...then try & call the .php page, you will be through.

    Best of luck

    Webcoder


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •