SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: prob in mail

  1. #1
    SitePoint Enthusiast Rami Yacoub's Avatar
    Join Date
    Oct 2004
    Location
    jordan
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question prob in mail

    hi every body
    iam trying 2 c the Mail package, nothing error but the mail not send
    and i don't know what 2 do....

  2. #2
    3MTA3
    Join Date
    Jul 2003
    Location
    Florida
    Posts
    1,016
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can you show us some code that does the mailing?

  3. #3
    WebAmoeba mythix's Avatar
    Join Date
    Aug 2002
    Location
    here
    Posts
    578
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    erm, can you give a better explanation...

    the code ur using, the platform, etc.
    Laws are like sausages. You have much more respect for them if you haven't actually seen how they're made.

    http://www.webamoeba.co.uk

  4. #4
    SitePoint Enthusiast Rami Yacoub's Avatar
    Join Date
    Oct 2004
    Location
    jordan
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Code

    i install the Mail backage
    PHP Code:
    <?
    include("Mail.php");

    $recipients "my@mydomain.com";

    $headers["From"]    = "from@domain.com";
    $headers["To"]      = "to@domain.com";
    $headers["Subject"] = "Test message";

    $body "TEST MESSAGE!!!";

    $params["host"] = "myHostIp";
    $params["port"] = "25";
    $params["auth"] = true;

    // Create the mail object using the Mail::factory method
    $mail_object =& Mail::factory("smtp"$params);

    if(
    $mail_object->send($recipients$headers$body)){
     echo 
    'it ok';
    }else{
     echo 
    'error';
    }
    ?>


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •