SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Bah! Verticle-Align Does Nothing!

    Arg! I've been trying to get this unordered list to align to the bottom of it's parent div and it seems to refuse to whatever I susept it to! It's driving me insane. Does anyone have some suggestions?

    http://www.lm85.com/index.php

    Thanks,

    Victor =]

  2. #2
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Perhaps you should read up on what vertical-align really does rather than relying on what you think it should do
    http://www.domedia.org/oveklykken/cs...ical-align.php

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I guess that certain resources (W3Schools For Example) aren't explaining it enough. This would explain Why I've never had any luch with it. Is there a way, however, to align a div to the bottom of it's parent?

  4. #4
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by legoman85
    I guess that certain resources (W3Schools For Example) aren't explaining it enough. This would explain Why I've never had any luch with it. Is there a way, however, to align a div to the bottom of it's parent?
    Yeah, set the parent's "display" property to "table-cell", but that won't work in IE. Or position it absolutely at "bottom: 0;" but that might not be exactly what you want.

  5. #5
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've tried to position it absolutely put that just pops it out of place. Seems that when I do that it forgets where it is! Lol. Perhaps I'll research more into the display: table-cell; idea.

  6. #6
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by legoman85
    I've tried to position it absolutely put that just pops it out of place. Seems that when I do that it forgets where it is!
    Absolute positioning removes the element from the page flow, which is why I said that it might not be what you want. Ask yourself if you really need bottom-positioned text, or if there isn't some other way to achieve it. Can you show the code you're trying to work with?

  7. #7
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help but I found a solution. I added a simple position: relative; to the parent div and away I go! Thanks again, I am SO glad I could get this to work, and in both IE and Netscape.
    Last edited by legoman85; Nov 7, 2004 at 21:23. Reason: Solution Found!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •