SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2004
    Location
    Niagara
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Issue with Custom Borders in FireFox

    Hey everyone, I'm new here but I've been perusing this forum for a little while. Anyways, I'm having some issues with my bands website. I'm trying to put custom borders around my DIV's, so I'll absolute position the image (which is very slightly larger than the DIV of course), and then I'll absolute position the DIV right over top of it. Which creates a border right around the section.

    I'm just starting to getting into Web Development and need some tips, but I've been programming for many years now in MFC, Java, and recently Perl and SQL.

    Anyways, here's a link to my template so you can see for yourself, it works fine in IE, but not Firefox. Actually it works for 2/3 of the borders, just not the menu (and I simply can't figure it out, it's not the right aligned text either).

    Template:
    http://home.cogeco.ca/~sleeptheseason/layout.html

    CSS Code:
    http://home.cogeco.ca/~sleeptheseason/style.css

    Any help would be greatly appreciated.

    Thanks!!!

  2. #2
    SitePoint Enthusiast
    Join Date
    Nov 2004
    Location
    Niagara
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I fixed my own issue, I took out the padding on the right for DIV.menu, and moved it to the P.menu class and now it seems to work. I thought I had tried taking that out before, but I guess I didn't. I guess it was just the div overlaying the border in Firefox, but for some reason it wouldn't in IE. They must handle padding quite differently.

    Thanks anyways,

    Justin


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •