SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Atlanta
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE6: Float not recognizing other floats

    I have a page with several floats that work correctly on Safari, Firefox, etc.

    The footer div (on IE6/Win) is a few hundred pixels too high on the page. I've checked my html and css and I can't figure out what is wrong. It should float below the others, but seems to ignore the floats on its "level" and only see the floats nested inside another div - weirdness. If anyone can help point me in the right direction, I would be very appreciative. I have read through Paul's article on floats in IE and I'm not sure it applies to this situation.

    Also, if you notice the light gray dividers throughout the site on Firefox or similar and then look at them on IE/Win, you'll notice that IE does not obey the width or negative margin applied to them. Any ideas on that as well? Thanks!

    Code: http://www.timothygray.com

    P.S. To see the float problem, click on the post entitled "Pardon the Dust" - it has less content and therefore shows off the bad float better.
    Last edited by timothygray; Oct 25, 2004 at 19:28. Reason: Missing info

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    I've only looked quickly but it seems you can froce the footer down by adding another clear above.

    Code:
      <div style="clear:both"></div>
      <div id="footer"> <span id="copyright">&copy; 2004 Timothy Gray | All Rights
    I'll have a look later and try and determine the real cause

    Paul

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Atlanta
    Posts
    75
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Great! That did it - thanks!

    So is that an IE bug or is that what it SHOULD do without a clear?

  4. #4
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    So is that an IE bug
    Hmm - I can't work out why its not clearing with the footer div. It should work without the extra clear. I thought there might be an error somewhere else or a missing tag somewhere but there doesn't seem to be.

    I'd have to deconstruct the page to get to the bottom of it but I'm a bit behind with a few things so if you can live with the extra clear for now and it may become apparent what's causing it later on.

    Paul


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •