SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Member
    Join Date
    Apr 2003
    Location
    Lubbock, Texas
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Firefox, Mozilla and Flash

    I have a page here that has a Flash slide show/banner on it. When you rollover the links in the navigation (or the links in the two content areas below the Flash) the Flash file appears briefly at the top left corner of the layout. I have only experienced this in Firefox and Mozilla for PC. The Mac versions are fine.

    Any ideas? This is driving me crazy.

  2. #2
    SitePoint Member
    Join Date
    Apr 2003
    Location
    Lubbock, Texas
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, since I found the fix, I thought I would post it. Here is the CSS code I WAS using:

    Code:
    #mainnav ul li a:hover {
    	display: block;
    	margin: 0;
    	color: #fff;
    	text-decoration: none;
    	padding: 5px 5px 6px 5px;
    	border-bottom: none;
    	background: #317dbf url(/mtd/g/rounded_corner_blue.gif) bottom right no-repeat;
    }
    Firefox/Mozilla was gagging on a changed padding and border for the bottom of the links in the hover state. I simply changed the padding to match all around and set the bottom border to 1px solid #fff. Here is revised code:

    Code:
    #mainnav ul li a:hover {
    	display: block;
    	margin: 0;
    	color: #fff;
    	text-decoration: none;
    	padding: 5px;
    	border-bottom: 1px solid #fff;
    	background: #317dbf url(/mtd/g/rounded_corner_blue.gif) bottom right no-repeat;
    }
    I forgot to mention that I thought it was odd that it affected the Flash file the way it did. Just strange.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •