SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict richtestani's Avatar
    Join Date
    Nov 2003
    Location
    Bridgeport
    Posts
    292
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cool what's the IE fix for this?

    I remember having this problem a few times, but everytime I come across it, I forget why IE adds padding to the bottom of elements.
    In this case it's the <ul> and <img>

    http://kimronemusdesign.com/
    RichTestani
    -------------------------------
    http://www.junkdepot.com
    http://www.rareoopdvds.com | The Movie Poster Site

  2. #2
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Have you tried removing the margins/padding from your ul?

  3. #3
    SitePoint Addict
    Join Date
    Mar 2003
    Location
    UK
    Posts
    245
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Use the css file to control the auto padding that IE (and other browsers) add to some HTML tags, I always add the below to my CSS file to get rid of tis uncontrolled spacing.
    Code:
    p, td, li, ul,ol, h1, h2, h3 ,h4 ,h5 ,h6 {
    	font: 10px/11px verdana, arial, helvetica, sans-serif;
    	/* Netscape 4&IE5 doesn't really like type tags just set in the body, this helps */
    	margin: 0 0 0 0; /* removes unpridictable 'browser default' settings */
    	padding: 0 0 0 0; /* " " */
    }
    img {
    	border: 0 none;
    	padding: 0 0 0 0; 
    }
    
    form {
    	margin: 0 0 0 0;
    }
    this should get rid of these anoying spaces.

  4. #4
    SitePoint Zealot Fiska's Avatar
    Join Date
    Jul 2004
    Location
    Dardania - Ancient Illyria
    Posts
    180
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This should solve your problem for ie:

    *html ul#yourstyle {padding : 0; margin : 0;}/*hack mode for non-compliant browsers => IE in quirks mode*/
    same would work for mozilla, just remove universal selctor (*html)
    I had the same problem, until Paul solved it for me

    You need explicitly to remove padding and margin for the given style.
    let's make things easier


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •