SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Sep 2004
    Location
    Italy
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    no syntax error nor debug messages

    Hi,

    I've have a client whose provider has all error messages in php turned off and I don't have access to php.ini. I don't get any messages for syntax errors or any debug info at all. Just a blank page.

    This is a big (huge) provider. Any ideas why they would do such a thing? Is it common? This is the first time I've run into it.

    What are my options? Any free syntax checkers available?

    Thanks.

  2. #2
    SitePoint Wizard Dangermouse's Avatar
    Join Date
    Oct 2003
    Posts
    1,024
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you can use .htaccess or error_reporting() to change it to E_ALL.

    .htaccess would be something like "php_value error_reporting E_ALL" or per script error_reporting(E_ALL);

    Or you could download apache/php with a similar environment to your host and develop on your computer, and just transfer the site when youre finished.

  3. #3
    SitePoint Member
    Join Date
    Sep 2004
    Location
    Italy
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, dangermouse. I tried adding error_reporting(E_ALL); to the top of my include file that gets included with all scritps, right after my session_start, but it made no difference. I also tried adding it just to the script that is giving me problems, but again I got not messages. I also tried adding ini_set("error_reporting", "E_ALL"); but that didn't give me any messages either.

    Am I doing something wrong or could it be that I can't change this?

    Thanks.

  4. #4
    SitePoint Wizard Dangermouse's Avatar
    Join Date
    Oct 2003
    Posts
    1,024
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    error_reporting(E_ALL) would work..

    Maybe you dont have any errors with php, could be something else? Why not the other thing i suggested.

  5. #5
    SitePoint Member
    Join Date
    Sep 2004
    Location
    Italy
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Dangermouse
    Maybe you dont have any errors with php
    Well, I can certainly fix that I deleted a semicolon at the end of a line following the call to error_reporting(E_ALL) and still just get a blank page.

    I definitely have some problem with this script. I changed a bunch of code things that were working stopped. There's an error in there somewhere.

    I don't know if I'm capable of setting up things on my machine (ie php, mysql, etc).

    I was really hoping for a free syntax checker I could download.

    I was also thinking of exporting the db and setting all this up on another provider I use that does have error messages turned on.

    Any idea why this provider would turn it off?

  6. #6
    SitePoint Member
    Join Date
    Sep 2004
    Location
    Italy
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Found the problem! I bit the bullet and installed iis and php and found a missing $ in front of a variable.

    Whew.

    Thanks for pushing me to install locally.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •