SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Mar 2003
    Location
    UK
    Posts
    245
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Form Validation in Firefox (PR1)

    I am having problems with my Form Validation script in Firefox (PR1).
    I am using a javascript to validate the fields. This works fine in IE, in Firefox though you can't click the buttons at the bottom of the form. The buttons dont even hilight when you mouse over them or 'press' when you attemt to click them.

    The page is [url=http://www.designed4hits.com/dev/hallmark/licence-enq.asp]here[/ur]
    I am sure this used to work with older versions of Firefox?

  2. #2
    SitePoint Zealot HardinComp's Avatar
    Join Date
    May 2003
    Location
    Boston, MA
    Posts
    171
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you by any chance have the Tabbrowser Extensions (TBE) installed in Firefox? There are known issues with that extension, including the fact that it breaks JavaScript.
    J.M. Hardin
    My blog
    Registered Ubuntu User #10980

  3. #3
    SitePoint Addict
    Join Date
    Mar 2003
    Location
    UK
    Posts
    245
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No TBE installed here. Itdid funky things when I upgraded to PR1 so I removed it.

  4. #4
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Yes it's weird but I found no problem when I made my own dummy JavaScript validation.

    Therefore it could probably be your CSS that is at fault because when disabled it gives me the Please enter your address [Alert], either that or my machine has faults - possible.

  5. #5
    SitePoint Addict
    Join Date
    Mar 2003
    Location
    UK
    Posts
    245
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for noticing the CSS thing, yep if I disable the CSS on the page I can click the button.
    This thing is all the CS does is resize the button. I have removed the class from the button, and it still doesn't work?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •