SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Zealot
    Join Date
    Aug 2003
    Location
    Great White North
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    nested lists in Firefox...

    I have created a navigation system that utilizes nested lists. The weird problem is that Firefox doesn't even seem to recognize the changes that I have made while IE implements them prefectly.

    Here is an example:



    The IE example is the look that I am trying to achieve.

    Here the portion of the stylesheet that governs the lists:

    Code:
    #tdSideNav {
    width:150px;
    background: #ccc;
    vertical-align:top;
    margin:0;
    padding:0;
    }
    
    #tdSideNav #siteSearch {
    margin-top:5px;
    padding: 5px 2px;
    background: #ccc;
    }
    #tdSideNav #siteSearch input {
    margin:0;
    padding: 0;
    }
    
    #tdSideNav ul {
    margin:0;
    padding:0;
    list-style-type: none;
    }
    
    #tdSideNav ul li {
    font: 12px verdana, arial, helvetica, sans-serif;
    color:#fff;
    list-style-type: none;
    border-bottom: 1px #993366 solid;
    }
    
    #tdSideNav ul li a {
    color: #fff;
    text-decoration: none;
    display: block;
    width: 148px;
    padding: 10px 0 10px 2px;
    vertical-align:bottom;
    }
    
    #tdSideNav ul li ul#subnav {
    list-style-type: none;
    margin-left: 4px;
    margin-bottom:5px;
    }
    
    #tdSideNav ul li ul#subnav li {
    border:0;
    }
    
    #tdSideNav ul li ul#subnav li a {
    padding: 3px 0 3px 20px;
    width: 120px;
    }
    
    #tdSideNav ul li ul#subnav li a:hover {
    border: 1px #ccc solid !important;
    margin: -1px;
    }
    and now the XHTML:

    Code:
    <td id="tdSideNav">
    	<div id="siteSearch">
    	Search<br />
    	<form action="" method="get">
    	<input name="" type="text" />
    	</form>
    	</div>
    	<ul id="ulSideNav">
    	<li><a href="default.php">News</a></li>
    	<li><a href="speeches.php">Speeches</a></li>
    	<ul id="subnav">
    	<li><a href="#">2004</a></li>
    	<li><a href="#">2003</a></li>
    	<li><a href="#">2002</a></li>
    	<li><a href="#">2001</a></li>
    	<li><a href="#">2000</a></li>
    	</ul>
    	<li><a href="media.php">Media Info.</a></li>
    	<li><a href="video.php">Video Clip Library</a></li>
    	</ul>
    	</td>
    I have cleared my cache numerous times, and can't seem to figure out what the problem is here.

    any ideas?

    Thx... COB

  2. #2
    SitePoint Zealot
    Join Date
    Aug 2003
    Location
    Great White North
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    nevermind....

    figured it out....

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    39,803
    Mentioned
    158 Post(s)
    Tagged
    4 Thread(s)
    Hi,

    You have constructed your lists incorrectly.
    Code:
    <ul id="ulSideNav">
    		<li><a href="default.php">News</a></li>
    		<li><a href="speeches.php">Speeches</a>
    		<ul id="subnav">
    		 <li><a href="#">2004</a></li>
    		 <li><a href="#">2003</a></li>
    		 <li><a href="#">2002</a></li>
    		 <li><a href="#">2001</a></li>
    		 <li><a href="#">2000</a></li>
    		</ul>
    		</li>
    <li><a href="media.php">Media Info.</a></li>
    		<li><a href="video.php">Video Clip Library</a></li>
    	 </ul
    The sublists should be inside the <li> element e.g. <li> <ul><li></li></ul> </li>

    Paul

    Edit:


    Whoops - I didn't notice that you'd figured it out

    Anyway its still good manners to post your answer for other people

  4. #4
    SitePoint Zealot
    Join Date
    Aug 2003
    Location
    Great White North
    Posts
    172
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'll remember that next time...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •