SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    Forensic SEO Consultant Webnauts's Avatar
    Join Date
    Jun 2003
    Location
    European Union
    Posts
    1,488
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Question to WCAG 13.6

    I am testing my web site with "aDesigner" from IBM, and I get a message:
    "Consider using intra-page links or providing more headings. Though there are intra-page links and headings, the arrival time to some content is over 120 seconds".

    Can someone tell what am I doing wrong? Thanks in advance.

  2. #2
    High fives all round! bradley317's Avatar
    Join Date
    Jan 2004
    Location
    Chester, UK
    Posts
    214
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like it's stuggling to find your content because you're not using heading correctly.

    Basically, its possible with most assistive technologies to skip through a pages content via the headings, then the headings within those until you find what you are after. It avoids having to read everything on a page if you are only interested in bits.

    Make sure your headings are structured correctly.

    eg

    <h1>Topic A</h1>
    <p>info info info info info</p>

    <h2>More about Topic A</h2>
    <p>info info info info info</p>
    <p>info info info info info</p>

    <h2>More about Topic A</h2>
    <p>info info info info info</p>
    <p>info info info info info</p>

    <h3>Even more about Topic A</h3>
    <p>info info info info info</p>
    <p>info info info info info</p>
    <p>info info info info info</p>
    <p>info info info info info</p>

    <h1>Topic B</h1>
    etc
    etc

    That should help.
    Hello, hello, what's all this shouting?
    We'll have no trouble here

    (Helping a pal... http://www.funkdub.info)

  3. #3
    Forensic SEO Consultant Webnauts's Avatar
    Join Date
    Jun 2003
    Location
    European Union
    Posts
    1,488
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bradley317 my headings are structured correctly.
    All pages have not this problem. Only the index.html page.
    Can you have a look here? http://www.webnauts.net

    Thanks.

  4. #4
    High fives all round! bradley317's Avatar
    Join Date
    Jan 2004
    Location
    Chester, UK
    Posts
    214
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It seems to run into problems at the point section beginning "Designing with accessibility and usability in mind". From here, it would take a while to read through all of the content, making the footer buttons fairly hard to reach.

    To be honest, I don't think you really have much of a problem. You've done a fine job of making this site accessible.

    I'm not sure if this would help, but you could try and make the "Section 508" and "W3C's Web Accessibility Initiative (W3C WAI)" into <H3> tags. Also, incorporating an <H1> somwhere in the footer would allow people to skip directly to that. You could hide it off the page with css if it won't fit into your design.

    Hope this helps
    Hello, hello, what's all this shouting?
    We'll have no trouble here

    (Helping a pal... http://www.funkdub.info)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •