SitePoint Sponsor

User Tag List

Page 2 of 2 FirstFirst 12
Results 26 to 27 of 27
  1. #26
    eCommerce specialist hotnuts21's Avatar
    Join Date
    Apr 2002
    Location
    Aberystwyth, UK
    Posts
    1,355
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK that seems to work
    Although I did have to hack the core code quite a bit to get it to work. Now just to apply some proper CSS to get it working just as I need
    Search & Rescue Aberystwyth Lifeboat
    CSS Tutorials/Guides

    Sitepoint signatures are not visible to Search Engines More info

  2. #27
    eCommerce specialist hotnuts21's Avatar
    Join Date
    Apr 2002
    Location
    Aberystwyth, UK
    Posts
    1,355
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK all seems fine and dandy. Untill I hit one of the sub menu links, then that becomes the active-link and so there are no <li> elements underneath it.

    What I need to do is append the class to the <UL>that the sub menu is in, would that still work with the CSS though?

    If i set the css to this
    Code:
     #navigation ul #active-link ul li a {
    		 color: #ffffff;
    }
    and had the html as
    Code:
    <li><a class="menu-link" href="content/section/2/25/">tutorials</a>
    <ul id="active-link" >
    <li><a class="menu-link"  href="content/view/6/28/">Testing for one</a></li>
    </ul>
    Search & Rescue Aberystwyth Lifeboat
    CSS Tutorials/Guides

    Sitepoint signatures are not visible to Search Engines More info


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •