SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    chown linux:users\ /world Hartmann's Avatar
    Join Date
    Aug 2000
    Location
    Houston, TX, USA
    Posts
    6,455
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)

    1and1 and $_POST vars

    I was doing some work on a client's site today and realized some of my code wasn't working. After a little investigating I found that even with a form's method set to "POST" the variables were still being past through the URI.

    Anyone know why it would be doing this? Server setting? I've never experienced anything like this, where I couldn't control the way the vars were passed.

  2. #2
    SitePoint Wizard silver trophy someonewhois's Avatar
    Join Date
    Jan 2002
    Location
    Canada
    Posts
    6,364
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You sure it was method="post" and nothing crazy? What browser? Would need to see code snippet.

  3. #3
    chown linux:users\ /world Hartmann's Avatar
    Join Date
    Aug 2000
    Location
    Houston, TX, USA
    Posts
    6,455
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Code:
    <form action="/prototype/admin/index.php" method="post">
    Is the form code... As soon as I hit the submit button I see all of the vars in the URI.

    And it is doing it in IE, Firefox, Netscape 7.2, and Opera.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •