SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Aug 2004
    Location
    Perth, Western Australia
    Posts
    166
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    XHTML - help please?

    Hello there, I'm new to this forum. I've been trying to validate my website for a while now and here are the last leftover errors. I can't seem to fix them. I've Googled some of the things mentioned and although I didn't find anything of use, one of the results led to a post on this website and I was hoping someone here would be able to help me out.

    *Note that this is a page that includes the entire website code structure, and the PHP includes on other pages point to this page. Things like forgetting to close the body and HTML tags I've already noticed but I can't fix them. Does this mean that I can't validate this "layout" page? Or is there a completely different solution altogether?

    Here's the URL to the validator page.
    http://validator.w3.org/check?uri=ht...m%2Flayout.php
    POSTED WITH CARE BY JORDIE, WEBMISTRESS OF WWW.A-SPLODE.NET

  2. #2
    Non-Member Egor's Avatar
    Join Date
    Jan 2004
    Location
    Melbourne, Australia
    Posts
    7,305
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    <div class="con" /> you cannot have a div like that.

    Why don't you validate the page with all the includes inside?

    That will solve all your other issues.

  3. #3
    SitePoint Zealot
    Join Date
    Aug 2004
    Location
    Perth, Western Australia
    Posts
    166
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mstwntd
    <div class="con" /> you cannot have a div like that.

    Why don't you validate the page with all the includes inside?

    That will solve all your other issues.
    Thanks - I'll give that a try.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •