SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Thread: CSS menu ?

  1. #1
    SitePoint Enthusiast
    Join Date
    Sep 2003
    Location
    pa
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS menu ?

    Lately, I have been making my menus using lists and get everything to where it is working properly. Then I click on a link in the menu and go to a new page and the background image menu moves up ever so slightly so that the background image it is not covering the menu bar completely like it was before. I have no idea why it's doing this? Why it would be right in one instance and then after clicking on a link it changes. Can anyone help me?
    You can sort of see what I am talking about at...
    http://www.lazerpro.com/projects/apartmentstore.com/

    Does it have anything to do with changing the page from html to php?

    Thanks for any help

    peace
    Summer

  2. #2
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Looks fine to me (Win/IE6), although the menu items are shifting onmouseover due to the border setting changes.

  3. #3
    SitePoint Enthusiast
    Join Date
    Sep 2003
    Location
    pa
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't mind the text shift upon hover...
    It looks alright in explorer but not in safari/netscape...

    so I added a height and that seems to work.

    Except, now, out of the blue, the Contact Us link is not in line with the other text links.

    I'm just learning CSS, but it seems to me that nothing stays the same. I am always having to add or take away something to make it work, even when using the same code on different sites.

    I gotta get a book.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •