SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict o~~Goatee~~o's Avatar
    Join Date
    Jan 2004
    Location
    North Yorkshire UK
    Posts
    350
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Full Text Indexing

    Hi there

    I've added a search field to my admin panel and used a WHERE CONTAINS statement to select the relevant data.

    I understand that I need to have Full Text Indexing enabled to use CONTAINS, but I can't seem to enable it. In Enterprise Manager, the option for enabling Full Text Indexing for a database or table is greyed out.

    Any ideas as to why the option is disabled and how I can get round it? Or maybe there is a better method for searching?

    Many thanks

  2. #2
    SitePoint Enthusiast BarbaraStreisand's Avatar
    Join Date
    Feb 2004
    Location
    New York
    Posts
    87
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Perhaps try executing this in QA:

    EXEC sp_fulltext_database 'enable'

  3. #3
    SitePoint Addict o~~Goatee~~o's Avatar
    Join Date
    Jan 2004
    Location
    North Yorkshire UK
    Posts
    350
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, thanks for the reply. I tried your suggestion and got the following error:
    Full-Text Search is not installed, or a full-text component cannot be loaded.
    Perhaps I need to look for something on my installation CD, if I can find it

    Cheers

  4. #4
    SitePoint Enthusiast BarbaraStreisand's Avatar
    Join Date
    Feb 2004
    Location
    New York
    Posts
    87
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Add/Remove Programs > Windows Components > Indexing Service

  5. #5
    \m/ R.I.P. Dimebag! \m/ JimBolla's Avatar
    Join Date
    Dec 2001
    Location
    erie, pa
    Posts
    1,130
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hah! i've been banging my head on this one for MONTHS! (not the whole time of course.) thanks barb. sure enough, no indexing service was installed.
    -- JIM BOLLA
    Wanna play Halo 2? My XBOX Live gamertag: crowdozer

  6. #6
    SitePoint Addict o~~Goatee~~o's Avatar
    Join Date
    Jan 2004
    Location
    North Yorkshire UK
    Posts
    350
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, sorry for the delayed reply.

    The Indexing Service was already installed. So I tried uninstalling and reinstalling, but no good Any ideas?

    Many thanks indeed


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •