SitePoint Sponsor

User Tag List

Results 1 to 19 of 19
  1. #1
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Page language <meta> tag

    Hi! This is my question :
    My page page language is French, with special French letters. This is the beginning of the HTML code.
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML>
    <HEAD><TITLE></TITLE>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    Nothing particular. But when I charge the page its default "view-code" is "cyrillic (windows)"! I've tried to introduce
    <meta http-equiv="Content-Language" content="fr">
    The same. I read other Frenche sites' HTML codes: same metas and normal "view - code" settings "Europe occidentale (windows)".

    Nevertheless, my page is displayed correctly: the special letters replaced with ISO codes are displayed as they must be. I just want to understand why this queer default "view" language. (The browser cant know, that I'm Russian , it must execute HTML!)

  2. #2
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is the page URL:
    http://ivakina.nm.ru/index.html. See yourselves.

  3. #3
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In the US version of Microsoft Internet Explorer 6.0, the code displays:

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    I think it may be your browser. I suggest trying a different browser.

    I hope I helped you!

    Au revoir!


    *Edit*

    Sorry, I just realized what you are talking about. The "view-code" in the US Internet Explorer is the "encoding". The source code says iso-8859-1, but the encoding in Internet Explorer says Cyrillic (Windows).

    I don't know why this is happening, but try changing ISO-8859-1 to UTF-8. I say that because ISO-8859-1 is the US/western division of unicode (UTF-8). ISO-8859-2 is the Central European division of the unicode character set. By using UTF-8, it will allow people from all over the world to view your site which will display the correct characters (instead of ?, it will say á, è, or any other character you want displayed.

    When in doubt, use UTF-8.
    Gohan (Mmm... Yummy!)

  4. #4
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,235
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    You can also set the language in the <html> element as well:
    HTML Code:
    <html lang="fr">
    ....
    </html>

  5. #5
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I tried the your two variants : UTF-8 and lang=fr. Nothing. The cyrilic characters are repalced with hierogliphs . But no correct characters if they are not replaced with &eacute; for é, &egrave; for è and so on.
    BUT, May it depond on my hoster (a Russian hoster)? When I open the page on my own server, the encoding (thanks, I was looking for the word ) is Europe occidantale, as I wanted. But when I read it in the Russian hoster, the encoding is Cyrillic (same HTML code)

    look:
    http://vitaalis.dyndns.tv/IVAKINA/ (my server)\
    http://ivakina.nm.ru (the Russian server I was talking about)

    If it is the reason, explain to me, how the server can influence the HTML code?

  6. #6
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Right, it's the Russina hoster that changes the encoding (I tried with another site - the same: Europe occidantal on my server and Cyrilic on the hoster), but HOW IS THAT POSSIBLE?

  7. #7
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You are already working it out in the other JavaScript thread (Forms...French is good...)

    Bonne chance!
    Gohan (Mmm... Yummy!)

  8. #8
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by gohankid77
    You are already working it out in the other JavaScript thread (Forms...French is good...)

    Bonne chance!
    Not sure the two have any connection. Not sure neither it is the same problem

  9. #9
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you mean the security settings and the problem with Cyrillic being the default encoding? I will research how to change the encoding using HTML.

    Je vais retourner!
    Gohan (Mmm... Yummy!)

  10. #10
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The cyrillic windows as default encoding must be resulted by the hoster (U've seen the encoding of two different URLs of the same page?). I dont think I can do anything about it in HTML code. As for the form, I dont think there s any connection with cyrillic installed on the machins. It may be security settings of the user (something like "dont send forms by mail", no idea). Just wanna know what it is, why it is and how to change it if possible.

  11. #11
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Je crois que j'ai un solution au problème de codage:

    http://www.webstandards.org/learn/askw3c/dec2002.html

    Rechercher de:

    to sum

    Lisez la liste de balles.

    J'espère que j'ai écrit tout correctement!



    In case you cannot read my poor French, here it is in English:



    I believe that I have a solution to the encoding problem:

    http://www.webstandards.org/learn/askw3c/dec2002.html

    Search for:

    to sum

    Read the list of bullets (the bulleted list).

    I hope that I wrote everything correctly!
    Gohan (Mmm... Yummy!)

  12. #12
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think the problem with Outlook Express could be because of security settings. Forms can be submitted using Outlook Express on my PC. I have Internet Explorer 6.0 for Windows Millenium Edition (Windows ME).

    Hope that helps you!
    Gohan (Mmm... Yummy!)

  13. #13
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It doesn't work, I ve already tried it befaore:
    The page with <meta http-equiv="Content-Type" content="text/html; charset=UTF-8> gives me cyrillic characters instead of ô or é in the code! (not when i replace them with &eacute; or &ocirc http://vitaalis.dyndns.tv/IVAKINA/ and hierogliphs on http://ivakina.nm.ru/. Althought the had the same HTML code
    The page with
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1> gives correct French letters on http://vitaalis.dyndns.tv/IVAKINA/ and cyrillic on http://ivakina.nm.ru. Same code too. See it, if u dont believe. So i think it must be the server. Tomorrow i ll try the xml.

  14. #14
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No problems with your French . it s really good. Now let s speak Russian?
    Merci pour collaboration

  15. #15
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you read the part about "Wrong" which is right after the "To Sum It Up" title? It says:

    Wrong. The webmaster sets a default character encoding to be sent by the server but does not let the author override it or the info is not provided anywhere whatsoever
    This basically says that Webmasters/hosts should not be allowed to specify the default character encoding and disable the Web authors ability to include characters such as &aacute; or &egrave;

    Unless you are using the same host in both links you just gave, the problem is with the second host. The XML idea will not work because if the host specifies a character encoding, the page will display that character encoding. I would contact your host if that is possible and see if you can get them to remove the default encoding or at least change it to UTF-8. This should display it.

    There is a way to override it, I believe. If you use an embedded font, it won't change the encoding, but it should display your necessary characters. It may take some time to load the page, but it is worth it to provide your guests with completely flawless content!

    I can't speak Russian!

    De rien.
    Gohan (Mmm... Yummy!)

  16. #16
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    U r right, it's the second host that worries me. It doesn't override my special characters, it just set cyrillic as default encoding. Given that it's a Russian server and meant to be used by Russian speaking sites, it must be right. I've never heard it was possible.

  17. #17
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I didn't know it was either until I searched. I'm glad I could help.
    Gohan (Mmm... Yummy!)

  18. #18
    SitePoint Zealot
    Join Date
    Jun 2004
    Location
    Paris
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you for your time!

  19. #19
    SitePoint Zealot gohankid77's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    C'était pas de problème.

    It wasn't a problem.
    Gohan (Mmm... Yummy!)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •