SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2000
    Location
    Norcross, GA
    Posts
    136
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    All modules and lib files are in the proper location and referred to in the conf file.

    Anything else known to cause this to happen?

  2. #2
    SitePoint Zealot
    Join Date
    Aug 1999
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you provide any more information?

    Have you told the server what types of file extensions to parse for PHP? ex: *.php, *.phtml, etc.?

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2000
    Location
    Norcross, GA
    Posts
    136
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    From the httpd.conf file:
    Code:
    LoadModule php4_module        modules/libphp4.so
    
    AddModule mod_php4.c
    
    <IfModule mod_php4.c>
      AddType application/x-httpd-php4 .php
      AddType application/x-httpd-php4 .php3
      AddType application/x-httpd-php4 .phtml
      AddType application/x-httpd-php4-source .phps
    </IfModule>
    =========

    I discovered that .php files are being parsed properly; in other words info.php displays the php info() screen just fine.

  4. #4
    SitePoint Zealot
    Join Date
    Aug 1999
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't have extensive knowledge on this, so I'm not sure about everything that would or would not work. However, on my server, I do not use <IfModule mod_php4.c>. I have the AddType line within the main part of the httpd.conf file.. for instance:

    LoadModule php4_module modules/libphp4.so
    AddModule mod_php4.c
    AddType application/x-httpd-php4 .php .php3 .phtml
    AddType application/x-httpd-source .phps

    Plus I have it within the directives for my domain:
    <Directory /home/directory>
    AddType application/x-httpd-php .php
    </Directory>

    This works for me. Other than that, I don't know anything.


  5. #5
    SitePoint Zealot
    Join Date
    Dec 2000
    Location
    Norcross, GA
    Posts
    136
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That fixed it. thanks.

  6. #6
    SitePoint Zealot
    Join Date
    Aug 1999
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    WOW... I feel smart now

    I'm glad you have it working!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •