SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Alabama
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    table question sort of

    ok... ive got a website and on this page http://www.eatarock.com/videos.htm there is a problem i have all of the links for the videos in tables and the tables cant be in line with the nav-bar to the left, for some reason the tables are always just under the nav-bar. this makes a gaping space and just looks bad. anyone know how to fix it? take a look at the source if you need to...

  2. #2
    Getting there... Willigogs's Avatar
    Join Date
    Aug 2003
    Location
    UK
    Posts
    394
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think it will be because all the tables have been set to have cellpadding of 9. (See Below)

    Code:
            <div id="content">
              <p><h1><font color="#FFFFFF" size="5">Videos -</font></h1>
                <table width="100%" border="0" cellspacing="0" cellpadding="9">
                        <tr valign="top"> 
                          <td width="50%"> 
                            <table width="100%" border="0" cellspacing="0" cellpadding="9">
                               <tr> 
                                <td><a href="http://www.eatarock.com/videos/tshirtfold.wmv">
    It's being used to space out the images so they aren't all bunched up, and this is a concequence.

    There are many ways to fix this problem. One possibility would be to remove the cellspacing and create a style for your table. Apply padding to the left, right and bottom - but not to the top.

    I'd imagine this should fix it?

    Code:
    table {
    	padding-right: 9px;
    	padding-bottom: 9px;
    	padding-left: 9px;
    }
    There may well be better ways to fix this which I'm sure other people will raise

  3. #3
    SitePoint Zealot
    Join Date
    Jan 2004
    Location
    Holland
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Width, margin

    Hmmm, tricky; you gave the menu a 21% width, and gave the content a 21% left margin to clear the menu, which it obviously doesn't.
    If you want to keep the fluid menu width, you could try enlarging the margin width by a percent or two and see if that works; alternatively, you could decide to give the menu a fixed (pixel) width and adjust the content margin width accordingly.
    With pixels, you could make a pixel-perfect fit; with percentages, there's always the risk of rounding errors, so a little play needs to be provided.

    Remember also that according to the W3C CSS box model the width property of an element specifies the width of the content area, without margins, padding and borders, whereas IE (5.x, 6.0 in quirks mode) incorrectly specifies the width property as the overall width, so including margins, etc. This alone may cause your layout to display differently on the various browsers.
    Regards,
    Ronald.

  4. #4
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Alabama
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Neither of those worked for me anyone else know how to fix it?

  5. #5
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you're missing a closing table tag. not sure if thats the problem though - but would be best to sort it out.

  6. #6
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Alabama
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    no, the closing table tag is in there......someone help me please!!!! i know someone has got to know how to fix this!!!

  7. #7
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    I'm not sure this is the problem you are talking about but on loading the page the images are just under the title "videos". When you mouseover the iinks on the left the images jump down about 3 inches below the links on the left.

    If this is the problem you are talking about (and even if its not) then it can be fixed by placing this line unde your content style in the css.
    Code:
    #content
    {
    font-size: 100%;
    background-color: rgb(0,0,0);
    color: rgb(225,0,0);
    border-left-width: 0px; border-right-width: 0px; border-top-width: 0px; border-bottom-width: 0px;
    border-left-style: none; border-right-style: none; border-top-style: none; border-bottom-style: none;
    padding: 29px 29px 29px 29px;
    border-color: rgb(0,0,0);
    text-align: left;
    }
    * html #content {height:1%}
    This will fix the jumping and the images will be just under the video title.

    You have a number of closing table/tr/td tags missing and a closing div tag missing also. There is an incorrectly nested anchor and a incorrectly nested paragraph. Run your page through the validator to fix these otherwise more errors may occur (you only have about 100 errors on that page lol).

    Hope that helps anyway

    paul

  8. #8
    SitePoint Enthusiast
    Join Date
    Jun 2004
    Location
    Alabama
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thank You

    THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU !!!!!!!!!!!!!!! thank you


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •