SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru Angry Coder's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    599
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Oracle: What's worng with my select statement? - Urgent :(

    Hello,

    I have wired problem... I have the fallowing tables:

    AccessLog:
    LID - Log ID
    EID - Employee ID
    etc...

    pr_emp:
    ID - Employee ID
    NAME - Employee Name
    etc...

    I have a record associated the an employee... but the my statment is always returning 0 row ... Here it is:

    Code:
    SELECT a.LID, e.ID, e.NAME FROM AccessLog a, pr_emp e WHERE a.EID = e.ID


    Please tell me what is wrong?

    Your help is greatly appreciated.
    Why It Doesn't Work?!

  2. #2
    SitePoint Guru Angry Coder's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    599
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Why It Doesn't Work?!

  3. #3
    SQL Consultant gold trophysilver trophybronze trophy
    r937's Avatar
    Join Date
    Jul 2002
    Location
    Toronto, Canada
    Posts
    39,350
    Mentioned
    63 Post(s)
    Tagged
    3 Thread(s)
    your query looks okay

    it's gotta be your data
    rudy.ca | @rudydotca
    Buy my SitePoint book: Simply SQL
    "giving out my real stuffs"

  4. #4
    SitePoint Guru Angry Coder's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    599
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You're right!

    Thank you...
    Why It Doesn't Work?!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •