SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    Old Fogey mancroft's Avatar
    Join Date
    Oct 2002
    Location
    lost
    Posts
    445
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    phpmyadmin error message: $cfg['Servers'][$i]['pmadb']

    Bona vada
    I have just set up a database and put two tables into it but phpmyadmin gives the following message (see below the actual question which comes next):
    My actual question is:
    what is $cfg['Servers'][$i]['pmadb']
    and how do I
    "just put your current database name in $cfg['Servers'][$i]['pmadb']"
    ????
    Thanks!



    >>>>>>>>>>>>>>>>>>>>>>>>
    Error
    The additional Features for working with linked Tables have been deactivated. To find out why click here.
    >>>>>>>>>>>>>>>>>>>>>>>>
    which leads to:
    >>>>>>>>>>>>>>>>>>>>>>>>
    Database cos_cart running on localhost
    PMA Database ... not OK[ Documentation ]
    General relation features Disabled
    >>>>>>>>>>>>>>>>>>>>>>>>
    and the link to documentation leads to:
    >>>>>>>>>>>>>>>>>>>>>>>>
    $cfg['Servers'][$i]['pmadb'] string
    Starting with version 2.3.0 phpMyAdmin offers a lot of features to work with master / foreign - tables. To use those as well as the bookmark feature you need special tables with a predefined structure, which we explain below.
    If you are the only user of this phpMyAdmin installation, you can use your current database to store those special tables; in this case, just put your current database name in $cfg['Servers'][$i]['pmadb'].
    If you are setting up a multi-user phpMyAdmin installation, you will need to create a new db and setup special privileges, so, as superuser:

    create a new database for phpmyadmin:
    CREATE DATABASE phpmyadmin;
    Note that "controluser" must have SELECT, INSERT, UPDATE and DELETE privileges on this database. Here is a query to set up those privileges (using "phpmyadmin" as the database name, and "pma" as the controluser):
    GRANT SELECT,INSERT,UPDATE,DELETE ON phpmyadmin.* to 'pma'@'localhost';
    do not give any other user rights on this database.
    enter the databasename in $cfg['Servers'][$i]['pmadb']
    >>>>>>>>>>>>>>>>>>>>>>>>
    :

    :

  2. #2
    SitePoint Member
    Join Date
    Jun 2004
    Location
    California
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    error

    Did you ever find a fix for this? I am having the same problem.
    I would appreciate your help with this issue. My email is gina@weblightstudio.com.

    Thanks,
    gina
    Quote Originally Posted by mancroft
    Bona vada
    I have just set up a database and put two tables into it but phpmyadmin gives the following message (see below the actual question which comes next):
    My actual question is:
    what is $cfg['Servers'][$i]['pmadb']
    and how do I
    "just put your current database name in $cfg['Servers'][$i]['pmadb']"
    ????
    Thanks!



    >>>>>>>>>>>>>>>>>>>>>>>>
    Error
    The additional Features for working with linked Tables have been deactivated. To find out why click here.
    >>>>>>>>>>>>>>>>>>>>>>>>
    which leads to:
    >>>>>>>>>>>>>>>>>>>>>>>>
    Database cos_cart running on localhost
    PMA Database ... not OK[ Documentation ]
    General relation features Disabled
    >>>>>>>>>>>>>>>>>>>>>>>>
    and the link to documentation leads to:
    >>>>>>>>>>>>>>>>>>>>>>>>
    $cfg['Servers'][$i]['pmadb'] string
    Starting with version 2.3.0 phpMyAdmin offers a lot of features to work with master / foreign - tables. To use those as well as the bookmark feature you need special tables with a predefined structure, which we explain below.
    If you are the only user of this phpMyAdmin installation, you can use your current database to store those special tables; in this case, just put your current database name in $cfg['Servers'][$i]['pmadb'].
    If you are setting up a multi-user phpMyAdmin installation, you will need to create a new db and setup special privileges, so, as superuser:

    create a new database for phpmyadmin:
    CREATE DATABASE phpmyadmin;
    Note that "controluser" must have SELECT, INSERT, UPDATE and DELETE privileges on this database. Here is a query to set up those privileges (using "phpmyadmin" as the database name, and "pma" as the controluser):
    GRANT SELECT,INSERT,UPDATE,DELETE ON phpmyadmin.* to 'pma'@'localhost';
    do not give any other user rights on this database.
    enter the databasename in $cfg['Servers'][$i]['pmadb']
    >>>>>>>>>>>>>>>>>>>>>>>>

  3. #3
    Old Fogey mancroft's Avatar
    Join Date
    Oct 2002
    Location
    lost
    Posts
    445
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Not really, i am afraid.

    I gave up on the web space provider and used someone else.

    If the problem relates to a setup on your machine, the answer lies in the config file but dunno exactly what.
    :

    :


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •