SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Zealot
    Join Date
    Feb 2004
    Location
    Cambridge, England
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    run time error line 67 object expected?

    I've created this html page http://homepage.ntlworld.com/julian..../template.html as a template for an online distance learning course. At the moment it is in its pilot stage and being tested on a few students. Someone has run into a problem. His comment is below:


    'Each time I access the test unit I get a browser message "run time error line 67 object expected"

    It is very irrittating and the system asks me if I want to de-bug. I say yes and get a screen of gobbl-dy-gook'


    Does anyone have any ideas what this might mean? I have asked him what platform and browser he is using. As yet, I haven't had a reply. I'm mystified, as the page was tested using a range of machines and browsers. We did have problems with older browsers, but recommended that they use newer versions of IE and Netscape.

    I would very much appreciate any help. I have'nt posted the code below, because the file is big, but it is available from the link I specified above.

    Many thank's,
    Philippa

  2. #2
    ☆★☆★ silver trophy vgarcia's Avatar
    Join Date
    Jan 2002
    Location
    in transition
    Posts
    21,236
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    That's a Javascript error in Internet Explorer for Windows. I wouldn't even trust that error message; IE is notorious for giving out wrong line numbers in their warnings.

  3. #3
    SitePoint Zealot colinr's Avatar
    Join Date
    Aug 2003
    Location
    san francisco, ca
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you don't have the function preloadimages() defined....
    thats the error..

    download mozilla firebird @ www.mozilla.com and use its javascript debugger for development, it saves alot of time... (Tools>>Javscript Console)
    Web Slave

  4. #4
    SitePoint Zealot
    Join Date
    Feb 2004
    Location
    Cambridge, England
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank's very much for you quick replies. I have now removed the offending 'function preloadimages'. That dated back to when I was using button rollovers, which I am no longer using. This was a piece of code that Golive generated and due to inexperience, it was something that I overlooked.

    Thank's also for the tip about mozilla.

    I very much appreciate your help.
    Philippa


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •