SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Apr 2004
    Location
    Barrow, Alaska
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help - Postion: relative; crashes IE Windows

    I have a small issue (large to me as I'm now three days into this problem) with trying to implement a table-less site with CF application I am developing.

    I've narrowed the issue down to the following code:

    div#main {
    position:relative;
    width: 75%;
    height: auto;
    margin: 0em 1 em 7em 13%;
    padding: 0;
    left: 8.5em; right: 1em; top: 7em;
    text-align: left;
    font-size: 10px
    }

    There is a container (width: 700px; postion: relative) with a content area (postion: relative) with a side menu (position: absolute) and this main area that must remain relative for the content area to stretch.

    Safari, Firefox (pc and mac), IE for Mac all work, but IE for windows crashes every time with postion set to relative.

    View at www.wildalaska.com/ravenpro/sfcss

    The css is located in the sfcss/styles/site.css directory.

    Any ideas?

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,350
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Any Ideas
    Yes - validate your code and the answers will be obvious

    You have some html outside of the body tags and this may be causing the crash.

    change the code to this:
    Code:
    </head>
    <body onLoad="MM_preloadImages('http://www.wildalaska.com/ravenpro/sfcss/images/gray_bullet_hl.gif')">
    <div id="container">
    <div id="content"> 
    
    Also at the end of the html change the code to this :
    Code:
     </form>
      &nbsp; Stories 1 to 4 of 6 <span class="right"> <a href="index.cfm?PageNum_Stories=2" >Next</a> 
      <a href="index.cfm?PageNum_Stories=2" >Last</a> </span> 
      </fieldset>
    </div></div>
    </div> 
    </body>
    </html>
    You closed the span tag with a div.

    Try that and then see if the problem still occurs.

    Paul

  3. #3
    SitePoint Member
    Join Date
    Apr 2004
    Location
    Barrow, Alaska
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Paul,

    Well, you're right - don't put code on the outside of body tags. Da!

    All is fine and dandy. Thank you for taking the time to help me through this.

    - Dave


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •