SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict Percipient's Avatar
    Join Date
    Jun 2000
    Location
    Summerland, BC, Canada.
    Posts
    226
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    A little while ago, I posted that I had a problem installing PHP on PWS 4. THat problem was solved, but I had need or reinstalling PWS (or at least I thought I did, so I did) and therefore had to re-install PHP. Now I get a 500 internal server error everytime I try to access a php page through the server. Any thoughts on what gives here?
    Ed Rands

  2. #2
    SitePoint Author Kevin Yank's Avatar
    Join Date
    Apr 2000
    Location
    Melbourne, Australia
    Posts
    2,571
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Sounds like PWS isn't finding PHP properly. A 500 error means the server was unable to process the request due to an error in the server-side script. In cases of PHP and PWS, this problem is usually that PWS is somehow misconfigured and cannot locate and run PHP.EXE.

    These kinds of problems are all too common with PWS. For this reason, I highly recommend using a different Web server. On my own development machine, I use Sambar Server (free) for local testing of PHP scripts. Check out my post here for instructions on setting up Sambar with PHP: http://www.sitepointforums.com/showt...ght=Sambar+PHP
    Kevin Yank
    CTO, sitepoint.com
    I wrote: Simply JavaScript | BYO PHP/MySQL | Tech Times | Editize
    Baby’s got back—a hard back, that is: The Ultimate CSS Reference


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •