SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    Non-Member coo_t2's Avatar
    Join Date
    Feb 2003
    Location
    Dog Street
    Posts
    1,819
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)

    permission problems?

    Hi. I'm having a problem on a virtual hosting account.
    I posted the problem on my host's support forums, but I figured in the meantime
    maybe one of you folks would know what might be causing this problem.

    If I run some code from an older file, it works, if I try to put the same code in a new file, it doesn't work. I've set the permissions to 0777, with a umask of 000. I've even tried creating the file with a PHP script, and then chmod it to 0777 with a umask of 000, both within the script that creates the file. But I can't get this code to run anywhere but the original file! It just seems to hang.(It's trying to run code from PEAR, BTW)
    Some of the PHP files are being required/included from another directory, but they
    are the same files that the original file(the one that works) uses.
    I really can't see a reason why the code would work ok from an older file, but not a newer one.

    I think they have done some upgrades of the servers, but I'm not sure what.
    Could this be some sort of ownership issue?

    --ed

  2. #2
    Idler. Chazzy's Avatar
    Join Date
    Jan 2004
    Location
    Uk
    Posts
    336
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, sounds like a CHOWN ownership problem... Although saying that if you as the user is able to chmod it 0777. Also try setting umask to 002 as opposed to 000


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •