SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Jun 2003
    Location
    Sofla
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Apache reading the wrong php.ini...

    Or rather, a non-existent php.ini. Please help if you can...

    Here's my problem. I just installed a fresh copy of Apache 1.3.29, and I'm trying to get PHP 4.3.4 to run with it (I'm running WinXP). Apache is running fine, and so is the basic PHP functionality - the thing is, I can't get any of the PHP extensions to load (like the GD images one).
    When I run php_info(), it says that the extensions directory is c:\php4, which is wrong. I have no directory called php4, and any changes I make to the php.ini file (placed in my system32 folder) are not reflected in php_info(). The php.ini I just placed in my system32 folder is the only one there.

    A couple of months ago I tried installing apache and php locally, but just erased it all after a day or two - I'm pretty sure I erased all of the .ini files and other settings as well, but it seems that the setting of c:/php4 as the extension directory is a holdover from back then.

    Why would apache not be parsing the php.ini in my system32 folder?

    Thanks!

  2. #2
    SitePoint Guru
    Join Date
    Jan 2001
    Location
    Alkmaar, Netherlands
    Posts
    710
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Copy your php.ini file to your %WINNT% directory. C:\Windows or c:\WinNT that you have installed your windows

  3. #3
    SitePoint Member
    Join Date
    Jun 2003
    Location
    Sofla
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    TRUE!!

    Thanks Sylow! ^_^ That got it.

    Now, why would it behave like that, if every piece of documentation says to drop it in the system32 folder?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •