SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Jan 2001
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've looked through this and re-looked through it many, many times. I can't find what's wrong with the code. In IE it works great, but in all NS versions (except 6) the table is about twice as wide as I specify. It appears to "push" further over further than I specify at the cells which house the "earthlightssmall3.jpg" and earthlightssmall4.jpg:"

    <table width="450" cellpadding="0" cellspacing="0" border="0">
    <tr>
    <td colspan="3" width="450" height="75"><img src="../graphx/earthlightssmall1.jpg" width="450" height="75" border="0" alt="Earthlights"></td>
    </tr>
    <tr>
    <td rowspan="2" width="100" height="150"><img src="../graphx/earthlightssmall2.jpg" width="100" height="150" border="0" alt="Earthlights"></td>
    <td colspan="2" width="350" height="75"><img src="../graphx/earthlightssmall3.jpg" width="350" height="75" border="0" alt="Earthlights"></td>
    </tr>
    <tr>
    <td colspan="2" width="350" height="75"><img src="../graphx/earthlightssmall4.jpg" width="350" height="75" border="0" alt="Earthlights"></td>
    </tr>
    <tr>
    <td colspan="3" width="450" height="50" align="center" valign="middle"><p><font face="Courier New, Courier"><span style="Font-Size : 14px">Earthlights.jpg (courtesy of <a href="http://www.nasa.gov/">NASA</a>)</span></font></p></td>
    </tr>
    </table>

    Thanks in advance for any code-solving!

  2. #2
    I'm a college yuppie now! sbdi's Avatar
    Join Date
    Jul 2000
    Location
    Dublin , Ireland
    Posts
    1,271
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you would probaly be better off using % instead of pixels i only glanced over the table but that normaly causes problems
    Back Again

  3. #3
    SitePoint Zealot honging's Avatar
    Join Date
    Jan 2001
    Location
    Chapel Hill, NC
    Posts
    160
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the first and last colspan should be 2, not 3, and all the other ones should be removed.

  4. #4
    SitePoint Member
    Join Date
    Jan 2001
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Honging! That didn't even cross my mind. Just a stupid mistake. Oh well, they say you can't proof-read your own work. They're right. Thanks.

    -Colin

  5. #5
    Don't get too close, I bite! Nicky's Avatar
    Join Date
    Jul 1999
    Location
    Lancashire, UK
    Posts
    8,277
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I can't quite see how the use of either % or pixels would casue problems. If there are any problems they are inherent to the design and coding NOT the use of certain tags and attributes.

  6. #6
    SitePoint Member
    Join Date
    Jan 2001
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    While I agree with Nicky fully, perhaps Sbdi was referring to flexibility rather than causing problems and just didn't explain it well? I know that percentages are much more flexible in terms of page display, but whether percentages or pixels are used shouldn't create any code flaws regardless.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •