SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict dtracker's Avatar
    Join Date
    Feb 2002
    Location
    Montreal, Canada
    Posts
    284
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Frames: really weird thing!

    Check Image Attached: http://www.diegoponce.com/chalet.gif

    I dont know why im not able to align (center) the tables on my top frame with the one on the bottom! I have exactly the same settings, is this Dreamwaver bug or what? HEEEEEELP!

    Top frame:
    HTML Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <body leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
    <table width="380" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    	<td><img src="images/top.gif" width="380" height="152"></td>
    </tr>
    <tr>
    	<td><img src="images/mid.gif" width="380" height="123"></td>
    </tr>
    <tr>
    	<td><img src="images/francais.gif" width="380" height="23"></td>
    </tr>
    </table>
    </body>
    </html>
    Frameset:

    HTML Code:
     <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "[url="http://www.w3.org/TR/html4/frameset.dtd"]http://www.w3.org/TR/html4/frameset.dtd[/url]">
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <frameset rows="302,100%" cols="*" framespacing="0" frameborder="no" border="0">
    <frame src="top.htm" name="topFrame" scrolling="NO" noresize >
    <frame src="bottom.htm" name="mainFrame">
    </frameset>
    <noframes><body>
    </body></noframes>
    </html>
    Bottom Frame:

    HTML Code:
     <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <body leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
    <table width="380" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    	<td width="379">texttexttexttexttexttexttexttexttexttexttexttexttexttexttexttext</td>
    </tr>
    </table>
    </body>
    </html>
    Attached Images Attached Images
    Peace - Paz - Paix

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,555
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    I haven't used frames for years but I think the problem is the scrolling="no" is in one frame but not the other. I think Ie reserves some space for the scrollbar.

    If you leave the scrolling out of the first one or put it in both then the layout lines up.
    e.g.

    Code:
    <frame src="top.htm" name="topFrame" scrolling="AUTO" noresize >
    <frame src="bottom.htm" name="mainFrame" scrolling="AUTO">
    Paul


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •