SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Feb 2004
    Location
    Maryland
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Help with IE6 rendering

    I'm trying to create a set of links using the hover attribute (or psuedo attribute) and for some reason IE6 is ignoring the font weight for the top link. It renders perfectly in NN 7, but I'm on the verge of tearing my hair out. I'm really quite new at this so forgive the use of tables, I haven't progressed that far yet. The really frustrating thing is I did a similar table on a previous page that worked fine. I've compared the two styles, but no luck. Here's the code:

    <html>
    <head>
    <title>Welcome to Chum Stain Sportfishing Charters!</title>
    <meta name="description" content=" ">
    <meta name="keywords" content=" ">

    <style type="text/css">
    body {background:#ffffff; margin:10px;}
    table {border:0; padding:2px; width:100%;}
    table td {border:0; padding:3px; vertical-align:top; text-align:center;}
    td#logoleft {font-size:100%; font-weight:600; color:black; width:130px; vertical-align:middle; font-family:arial, verdana, sans-serif;}
    table#links {width:130px;}
    table#links td {background:transparent URL(ripple2.jpg); border-bottom:1px solid #ffffff;}
    a:link {color:#333399; font-size:100%; font-weight:700; text-decoration:none; font-family:arial, verdana, sans-serif;}
    a:visited {color:#333399; font-size:100% font-weight:700; text-decoration:none; font-family:arial, verdana, sans-serif;}
    a:hover {color:#ff00cc; font-size:100%; font-weight:700; text-decoration:none; font-family:arial, verdana, sans-serif;}


    </style>
    </head>

    <body>
    <table cellspacing="0">
    <tr>
    <td id="logoleft">Inshore fishing, Offshore fishing,<br />and Cruising</td>
    <td><img src="chumlogo1.jpg" width="451" height="134"></td>
    <td id="logoleft">Sailing from<br />Wildwood New Jersey<br /></td></tr></table>
    <hr color="#3333cc">
    <table>
    <tr><td>
    <table id="links">
    <tr><td id="links"><a href="captain.html">Your Captain</a></td></tr>
    <tr><td id="links"><a href="charters.html">Charters & Cruising</a></td></tr>
    <tr><td id="links"><a href="rates.html">Rates & Info</a></td></tr>
    <tr><td id="links"><a href="bring.html">What to bring</a></td></tr>
    <tr><td id="links"><a href="mailtoxxxx@msn.com">E-mail Us</a></td></tr></table>
    </td>
    <td>

    I'd appreciate any ideas you may have.

  2. #2
    SitePoint Member
    Join Date
    Feb 2004
    Location
    Maryland
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question

    Just noticed I had extra code in the cells for the links but removing it did nothing.

  3. #3
    SitePoint Member
    Join Date
    Feb 2004
    Location
    Maryland
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question

    Oh brother, found the mistake! Left out a semi-colon in the a:visted properties. Thanks for putting up with me.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •