SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Toronto, ON, Canada
    Posts
    72
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    loadVariablesNum problems

    I use loadVariablesNum ( "flashVars.txt",0 ); to load some variables in frame 1 then in frame 2 I use:

    tellTarget ("Bar1") {
    gotoAndStop (/:bar1);
    }

    where bar1 is a variable from the file with a value of 10 and I want clip "Bar1" to gotoAndStop at frame 10 of the clip. All works well if I set a variable, but it will not recognize the values from the file. If I use a text field to bar1 it shows the 10 just fine. Why does my tellTarget not work?

    Thanks

    Rob.

  2. #2
    Dumb PHP codin' cat
    Join Date
    Aug 2000
    Location
    San Diego, CA
    Posts
    5,460
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you using Flash 4 or something? What version of flash are you using. If its MX, I would suggest using LoadVars() and . syntax vs. Flash 4 / syntax
    Please don't PM me with questions.
    Use the forums, that is what they are here for.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2003
    Location
    Toronto, ON, Canada
    Posts
    72
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am using Flash 5.

    Thanks for your help.

    Rob.

  4. #4
    SitePoint Guru JoePrice's Avatar
    Join Date
    Jan 2002
    Location
    UK
    Posts
    673
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeah avoid the tell target malarky if you can
    . syntax is far easier to use

  5. #5
    SitePoint Enthusiast
    Join Date
    Feb 2004
    Location
    Canada
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    try

    _root.bar1.gotoAndStop(1);

    forget the telltarget crap.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •