SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Jun 2000
    Location
    Canada
    Posts
    161
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    I just downloaded Opera 5 to see how my sites are displayed with it...they are all fine except for one small thing: the browser detects it as IE so it loads the same pages as in IE but I see that my animated logo is running at about 60 fps as in Netscape! What is the code to redirect Opera or to detect it?

    Thanks in advance.

    Cheers!
    CG Focus

    Focusing On CG Graphics.

  2. #2
    SitePoint Enthusiast Chip D's Avatar
    Join Date
    Nov 2000
    Location
    Ontario, Canada
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Opera's profile shows up as the following (when running on a Win 98 machine), "Mozilla/4.0 (compatible; MSIE 5.0; Windows 98) Opera 5.0 [en]"

    Unfortunately, it is exactly the same as IE apart from the Opera 5.0 [en] on the end. If you can find a way to get your script to ignore the MSIE and only recognise the Opera 5.0 [en] on the end then it should work. I don't know how to do this myself . . . at the moment, but, one day . . .

    Hope ths helps a bit at least.
    Chip D
    ----------------------------------------------------
    Chances are what I think I'm typing is nothing like what I type.

  3. #3
    Irritability Defined
    Join Date
    Jul 2000
    Location
    80,000 feet below the surface
    Posts
    1,442
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Chip is correct. However, Netscape have come up with a browser sniffer that accurately detects Opera and the other browsers too :

    http://developer.netscape.com/docs/e...wser_type.html
    My 2 Cents (or is that 2.2 Cents including GST?)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •