SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My Dodgy Old Computer! Part 2: FDISK

    Ok after much distress at my computer (thread: http://www.sitepointforums.com/showt...hreadid=14198) I have decided I need to sort out my computers hard drive, I managed to get Fdisk to create a new extended partition with a logical drive on it. ok sounds fine, but when I create the drive, it get's set as drive 'D' (without a choice). Still fine people may say, but my CD drive is drive 'D'. therefore everytime I start windows, it crashes!

    I don't know if it's an old version of Fdisk or something but how can I set what drive letter it is?

  2. #2
    SitePoint Wizard
    Join Date
    Sep 1999
    Posts
    1,390
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try booting into safe mode. In safe mode, you should be able to change the drive letters (I think you can change both hard drive and CD drive letters).

    Your CD drive doesn't have to be D. My old computer has the CD drive on E, and on this computer I have CD drives G and H.

    I am pretty sure you can't change the drive letters in any version of FDISK.

  3. #3
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I tryed booting into safe mode, and running fdisk off a boot disk but with no such luck.

    I don't really want to change my CD drive letter; the drivers for it were a pain to find (it's a faily old CD drive), all my games will have to get reinstalled (most need the CD inserted into the same drive as the game was installed off) and drive D has always been my CD drive, my family (not really computer literate) have finally leart D is the CD drive so it would be a bit of a pain.

    there must be some way to set it so I can choose which letter I want, or somehow it must be able to pick up that drive letter D is already in use!

  4. #4
    SitePoint Wizard
    Join Date
    Sep 1999
    Posts
    1,390
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't try to use FDISK off of a safe-mode boot. It won't work, as you figured out.

    Instead, boot into Safe mode and change the drive letters in System Properties (I am very sorry for not being clear the first time around). System Properties is under the Windows Control Panel.

    Good luck!

  5. #5
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok cheers, I'll give that a go then

  6. #6
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My Dodgy Old Computer! Part 2: FDISK

    OK, i tryed what you said but without luck:

    I started it in safe mode
    - went to control panel
    - then to system
    - then to devices
    - to the CD drive
    - but could not change the drive letter! - it was greyed out with the original letter (D) in the text box, underneith there were 2 drop down boxes with something about where to start and finish the drive letter??? not sure if that was it - I tryed setting both to drive 'F' (to change the CD to drive F but that didn't work!

    I tryed creating a new drive partition (automatically named drive D, restarted in safe mode but could not find where to change that drive letter.

    If you mean system properties by right clicking on the system icon and going to properties, then no luck either, that was disabled (I couldn't click it) in safe mode and normal!

    So unless you mean't change the drive letter by other means (can you do it in dos with some sort of command?) then I am completely stumped!!

    any other suggestions anyone?
    <Edited by daniel_eastley on 01-07-2001 at 05:30 PM>

  7. #7
    Your Lord and Master, Foamy gold trophy Hierophant's Avatar
    Join Date
    Aug 1999
    Location
    Lancaster, Ca. USA
    Posts
    12,305
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Look in your AutoExec.bat for a line similar to:

    mscdex.exe /D:something.sys /L:D

    Remove the /L:D from that line or change it to the drive letter of your choice.

    If you have an IDE CD-ROM drive and don't boot into DOS mode, remove the line completely.

    If you remove it then look in the Config.sys file and corresponding Device driver there. (would match the /D:somthing.sys statement).
    Wayne Luke
    ------------


  8. #8
    SitePoint Wizard wdmny's Avatar
    Join Date
    Jul 2000
    Location
    Here
    Posts
    1,010
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This might work....

    1. Boot from a boot disk that has CD-Rom support
    2. Choose to load the CD-Rom drivers
    3. Delete your new partition
    4. Create it again

    Since the CD drive is already assigned in DOS, FDISK should not make it D:, but E:, or a drive that is unused. When you boot into DOS, you don't have CD-Rom support, so to DOS, your D: drive doesn't exist. When FDISK set your partition at D:, it was becuase D: was unused.

  9. #9
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Web Desmony:

    but even If I exit windows with 'restart in MS DOS mode' selected, the CD drivers won't be loaded? cause I tryed that and it done the same thing, any way I'll give it a go and see what happens

    thanx


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •