SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict
    Join Date
    Feb 2003
    Location
    Berlin
    Posts
    370
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problems compiling PHP: png.h not found.

    I'm just trying to install my LAMP Server. Everything went well so far. The last step is getting PHP installed.

    now this is how I want it to be configured:

    PHP Code:
    ./configure 
    --prefix=/usr/local/php-4.3.4 
    --with-apxs2=/usr/local/apache/bin/apxs 
    --with-mysql=/usr/local/mysql
    --
    with-pdflib=/usr/local
    --
    with-zlib-dir=/usr/lib
    --
    enable-track-vars=yes 
    --enable-magic-quotes 
    --enable-url-includes 
    --enable-sysvshm=yes 
    --enable-sysvsem=yes 
    --enable-ftp 
    --with-config-file-path=/usr/local/php
    --
    with-gd 
    --with-jpeg-dir=/usr/lib
    now, my first Problem was, that the "libjpeg.so" was missing - I found the libjpeg.so.62 on my System and made a ls - n to it with "libjpeg.so".
    Now the same problem accured with libpng - no problem again a link...

    But now it says

    "configure: error: png.h not found."

    what ist png.h - couldn't locate this on my System (except in /users/floezen/PDFlib-Lite-5.0.2-Unix-src/libs/png/png.h which is the source for the PDFlib installation).
    Now - where should png.h be and how can I install this?

    Hope someone can help me

    Floezen

    P.S.
    This is a RedHat 9 Linux distribution.

  2. #2
    SitePoint Member
    Join Date
    Jan 2004
    Location
    Columbia, SC
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You need libpng-devel-1.2.2-8.i386.rpm installed on RH9. It's on disc 1.

  3. #3
    SitePoint Member
    Join Date
    Apr 2001
    Location
    San Diego, CA
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have the same problem on my Cobalt RAQ4 server. I installed libpng 1.2.5 again but it still isn't working
    Mike Henderson
    NFSGarage

  4. #4
    SitePoint Addict
    Join Date
    Sep 2003
    Location
    Europe
    Posts
    222
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You need to install the development package (libpng-devel-something)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •