SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    Super Ninja Monkey Travis's Avatar
    Join Date
    Dec 2001
    Location
    Sioux City, Iowa
    Posts
    691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    <pre> kills layout in IE

    On http://realistanew.com I wrote an entry that uses <pre> to show some code. For some reason this breaks in IE6. I lose my blue background color and the whole site becomes left aligned. I tried using a <code> tag and doing white-space: pre; but I got the same effect. Anyone know why this might be?
    Travis Watkins - Hyperactive Coder
    My Blog: Realist Anew
    Projects: Alacarte - Gnome Menu Editor

  2. #2
    Ceci n'est pas Zoef Zoef's Avatar
    Join Date
    Nov 2002
    Location
    Malta
    Posts
    1,111
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No I don't. Because funnily enough on IE5.0 it looks fine and I haven't got IE6 installed here.

    'pre' can be very tricky since you'll never be able to predict how wide it will turn out. Why don't you start with putting a width on the 'pre' (and overflow:auto). It might also help to have that code indented with spaces rather then with tabs. (so it doesn't take up so much space in the first place).

    Rik
    English tea - Italian coffee - Maltese wine - Belgian beer - French Cognac

  3. #3
    Super Ninja Monkey Travis's Avatar
    Join Date
    Dec 2001
    Location
    Sioux City, Iowa
    Posts
    691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Changing them to spaces did the trick, thanks.
    Travis Watkins - Hyperactive Coder
    My Blog: Realist Anew
    Projects: Alacarte - Gnome Menu Editor

  4. #4
    Ceci n'est pas Zoef Zoef's Avatar
    Join Date
    Nov 2002
    Location
    Malta
    Posts
    1,111
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Welcome mate!

    Rik
    English tea - Italian coffee - Maltese wine - Belgian beer - French Cognac

  5. #5
    SitePoint Wizard edshuck's Avatar
    Join Date
    Jul 2000
    Posts
    1,200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi

    Using IE, I get foo and bar. but using Mozilla, i go to your page, with program.

    I have IE 6.0.28 installed. and mozilla 1.5


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •