SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question installing entropy.ch PHP package

    Hi all,

    I'm running Mac OS X which ships with a default installation of both Apache and PHP (the default PHP installation on my machine is 4.1.2). Just recently I downloaded and installed the http://www.entropy.ch/software/macosx/php/ PHP package, which has a more recent PHP release, as well as a more refined custom setting. Upon install though, my phpinfo(); file showed that my Mac was still running the default Apple PHP install. How should I go about activating the latest install?

    Thanks for any responses,

    mudshark

  2. #2
    Super Ninja Monkey Travis's Avatar
    Join Date
    Dec 2001
    Location
    Sioux City, Iowa
    Posts
    691
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you restart Apache after installing this? You need to for any changes to take effect.
    Travis Watkins - Hyperactive Coder
    My Blog: Realist Anew
    Projects: Alacarte - Gnome Menu Editor

  3. #3
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I turned off "Personal Webserver" in System Prefs, then turned it back on again, yes... that didn't seem to help any. Unless I need to do this via "Terminal"? I really am a Unix virgin lol, should I be doing some stuff at command prompt? If so: help!

  4. #4
    Atomic Robot Man pezagent's Avatar
    Join Date
    Oct 2003
    Location
    New Zealand
    Posts
    266
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi mudshark,

    I've installed Marc's PHP package as well, I think initially if you're getting the same php info there could be any number of very simple solutions. The installer removes all previous versions of PHP so you shouldn't have any problems--especially if you restart Apache. You don't need to restart it through the terminal if you've done it in System Preferences. You might want to check out Marc's forum at Entropy where you will probably have a better time finding the specific solution to your problem based on your setup. It could be something as simple as the browser cache not updating your request page. This is especially true with Safari.

    Please let us know how you get along.

    /johnny
    SQLZoo | ZVON Xlab
    May the Source Be With You
    When the app is ready, the oop will appear...

  5. #5
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi pezagent, thanks for your response.

    I've tried getting around the cache thing by opening my phpinfo file in another browser (IE 5 Mac), but I got the same result. You're right, the entropy forums have a wealth of information but until now I didn't find my specific problem tackled there. I've posted a thread, no response yet.
    If and when this thing gets resolved, I'll drop a note...

    mudshark

  6. #6
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problem solved!
    Someone responded to my thread at entropy with the following advice:

    QUOTE:
    "I solved the problem by changing the httpd.conf file. In that file you see something like 'Loadmodule php4_module' with a path name behind it. This pathname should be /usr/local/php/libphp4.so. This worked fine with me and solved the problem. After a pretty long search I got that 'hint' from a file enclosed with Php package. That file name is httpd.conf.php. So my conlusion is that the http.conf file is not adjusted with the pathname during installing the package of Marc."

    There you go. It helped me out, maybe it'll help someone else out...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •